Updated image available [2014-03-07]

http://automagucally.weebly.com

Moderators: davka003, Telldus

KHolm
Posts: 163
Joined: Thu Jan 18, 2018 11:08 am

Updated image available [2014-03-07]

Post by KHolm » Thu Jan 18, 2018 11:08 am

Hi,

A new image for a 4Gb SD card has been created based on the latest version of Automagically (2014-03-07).

Found here: Attached as torrent
Found here too: https://www.dropbox.com/s/iew29kepqazqz ... _03_07.zip
MD5 of img file inside the zip: 7a01756348469a45d4646650553291e0
Size of the file: 1,33 GB (1 435 557 632 byte)
Based on sourcecode revision: 5a23f6d
Source repository and issue tracker: https://bitbucket.org/davka003/automagically/
UserID for console/ssh/admin interface: pi
UserID for mysql: root
Password for the above: raspberry

Instructions how to install and use
http://automagically.wikia.com/wiki/Automagically_Wiki

How to replicate
The image was created using these instructions:
https://bitbucket.org/jorkar/automagically_install

Removed stuff from the configuration
- Removed all /core/ items
- Removed all /signals/ items
- Clean /etc/tellstick.conf

Added a test device and accompanying remote
- A single Raw Tellstick Device called Test is available
- A single Remote named Main with a page Home having a single On/Off called Test

Changes from 2013-02-22 image
  • Fixed issue with missing module, pyephem
  • Updated to latest Automagically version
  • Updated to latest rasbian
Final touch
You might want to make use of the full partition of your SD card. Run raspi-config and Expand Filesystem

Code: Select all

$ sudo raspi-config
/Marcus
Attachments
automagically_2014_03_07.torrent
(13.79 KiB) Downloaded 441 times
Last edited by KHolm on Sun Mar 23, 2014 5:42 am, edited 4 times in total.

misterleffe
Posts: 57
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by misterleffe » Thu Jan 18, 2018 11:08 am

I've downloaded your image from the torrentfile and installed it properly. Has expanded the filesystem as you suggest. I've put the plugins wem and googlespread in the plugin directory. I have made 1 Transform and send it to Xively, but it's not popping up there. But it will not play properly ... The image is "clean" as you made it but it seems to "hang" when I'm in the Site administration pages. E.g. when changed values in System settings, I didn't get any "Saved". It just saying "waiting for ..." I rebooted the Pi and when I had a look in the Systems settings, the new changed values was there!

If I try to use the Signal handler, I can toogle it on/off, but I won't get any updated list when making "Refresh" of the Signal handler.

There is no problem to switch pages, but it's the "commands" that Automagically won't do!

What's wrong?



/misterleffe

KHolm
Posts: 163
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by KHolm » Thu Jan 18, 2018 11:08 am

I'll see if I can find some time to dig into this tomorrow, no promises.
For now - don't use this image.

/Marcus

KHolm
Posts: 163
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by KHolm » Thu Jan 18, 2018 11:08 am

Hi,

I cannot repeat your issue. I plugged in the SD card from which I created the image and it works just fine.
I can change settings and enable signal traces without any issues. I could also add a signal transform and feed xively.

Tomorrow I'll try to "burn" the SD again to that I start from scratch.

But at least I cannot reproduce the faults you mention from the source of the SD.

/Marcus

KHolm
Posts: 163
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by KHolm » Thu Jan 18, 2018 11:08 am

KHolm wrote:I'll see if I can find some time to dig into this tomorrow, no promises.
Cannot reproduce your error mrleffe.

Burned a new SD card with the 2013_03_07 image, note the MD5 hash:
writer_hash.JPG
writer_hash.JPG (28.33 KiB) Viewed 15460 times
Started up the system and fetched the latest ( 0.8 ) wem.py:
puttydump.JPG
puttydump.JPG (102.67 KiB) Viewed 15460 times
Configured wireless energy meter and xively plugin settings, which works just fine:
save_settings.JPG
save_settings.JPG (18.38 KiB) Viewed 15460 times
And then enabled signaltrace:

Code: Select all

2014-03-23 06:29:36.955458	system	xively,configuration,changed 	
2014-03-23 06:29:37.143895	system	xively,configuration,changed 	
2014-03-23 06:29:37.291318	system	xively,configuration,changed 	
2014-03-23 06:29:53.692444	tellstick	tellstick,raw:class:sensor;protocol:fineoffset;id:69;model:temperaturehumidity;humidity:67;temp:28.0; 	
2014-03-23 06:29:53.698611	tellstick	tellstick,sensor,protocol:fineoffset,id:69,Temperature,value:28.0 	
2014-03-23 06:29:53.703432	tellstick	tellstick,sensor,protocol:fineoffset,id:69,Humidity,value:67 	
2014-03-23 06:29:53.867163	tellstick	tellstick,raw:class:sensor;protocol:fineoffset;id:68;model:temperaturehumidity;humidity:68;temp:27.9; 	
2014-03-23 06:29:53.875698	tellstick	tellstick,sensor,protocol:fineoffset,id:68,Temperature,value:27.9 	
2014-03-23 06:29:53.881284	tellstick	tellstick,sensor,protocol:fineoffset,id:68,Humidity,value:68 	
2014-03-23 06:29:54.735229	wem	wem,data;status:OK;datetime:2014-03-23T06:29:01.848646;seq:67;energy:280.0;packetloss:0;pmom:19.37155; 	
2014-03-23 06:29:54.747141	wem	xively,report:Energy:280.0:W,Pmom:19.37155:kWh; 	
2014-03-23 06:30:10.932991	tellstick	tellstick,raw:class:sensor;protocol:oregon;model:EA4C;id:66;temp:2.6; 	
2014-03-23 06:30:10.937965	tellstick	tellstick,sensor,protocol:oregon,id:66,Temperature,value:2.6 	
2014-03-23 06:30:11.089597	tellstick	tellstick,raw:class:sensor;protocol:oregon;model:EA4C;id:66;temp:2.6; 	
2014-03-23 06:30:11.095503	tellstick	tellstick,sensor,protocol:oregon,id:66,Temperature,value:2.6 
System works like a charm, so I cannot say there is anything wrong with the image. Seems the issue is on "your" side.

#1 - Check the MD5 of your downloaded image
When opened Win32 Disk Imager, select the image and click "MD5 Hash". Should result in: 7a01756348469a45d4646650553291e0

#2 - Try another SD card, there might be issues with your SD card
I personally had issues with an old Transcend card that were too slow resulting in strange behaviours

#3 - Run a clean system, without any WiFi adapters or anything but the Tellstick connected

#4 - ??

/Marcus

Raz
Posts: 6
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by Raz » Thu Jan 18, 2018 11:08 am

finns det några planer för en ny image med tellus core 2.1.2? telldus-core ser inte ut att vara installerat via pakethanteraren (?). finns det något enkelt sätt att uppdatera till senaste version?

rioh
Posts: 5
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by rioh » Thu Jan 18, 2018 11:08 am

Raz wrote:finns det några planer för en ny image med tellus core 2.1.2? telldus-core ser inte ut att vara installerat via pakethanteraren (?). finns det något enkelt sätt att uppdatera till senaste version?
Trots skrala linux-kunskaper lyckades jag lägga in 2.1.2 själv i min Raspberry, med hjälp av bl.a. denna http://developer.telldus.com/wiki/TellS ... tionUbuntu

mvh
RiOh

Raz
Posts: 6
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by Raz » Thu Jan 18, 2018 11:08 am

rioh wrote:
Raz wrote:finns det några planer för en ny image med tellus core 2.1.2? telldus-core ser inte ut att vara installerat via pakethanteraren (?). finns det något enkelt sätt att uppdatera till senaste version?
Trots skrala linux-kunskaper lyckades jag lägga in 2.1.2 själv i min Raspberry, med hjälp av bl.a. denna http://developer.telldus.com/wiki/TellS ... tionUbuntu

mvh
RiOh
Ok, det ska jag nog fixa. Lyckades du rensa bort befintlig version på något bra sätt eller körde du bara över den tidigare versionen?

rioh
Posts: 5
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by rioh » Thu Jan 18, 2018 11:08 am

Jag körde över den befintliga, (men gjorde förstås en backup på kortet först)
Tycks minnas att jag fick en fråga om att skriva över /etc/tellstick.conf och /etc/init.d/telldusd, så jag backade upp de befintliga
Den nya telldusd var jag tvungen att sätta in för att det skulle funka, de skilde sig ganska mycket, men hursomhelst, jag kan logga regn- och vindsensorerna från oregon så jag är nöjd!

Raz
Posts: 6
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by Raz » Thu Jan 18, 2018 11:08 am

Tack för svar. Jag rensade utifrån http://elinux.org/R-Pi_Tellstick_core och "Example output". Får nu in sensorvärden som jag vill.

ejansson
Posts: 1
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by ejansson » Thu Jan 18, 2018 11:08 am

Hej.

Är detta den senaste versionen av automagically?
Var kan jag ladda ner denna, torrent-länken som finns högre upp i tråden är död (stannar vid ~24% och dropbox länken fungerar inte längre.

Tack på förhand.

sjostrom
Posts: 2
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by sjostrom » Thu Jan 18, 2018 11:08 am

Hej!

Jag fick hem den via torrent. Jag hjälper till och seedar ett tag.

joonah
Posts: 2
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by joonah » Thu Jan 18, 2018 11:08 am

Hi,

I would appreciate if someone could seed the torrent for a bit, I will make sure my server seeds it for the foreseeable future afterwards.

Thanks!
Jonatan

joonah
Posts: 2
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by joonah » Thu Jan 18, 2018 11:08 am

Got it now, I will put it on my server during the weekend.

snav
Posts: 31
Joined: Thu Jan 18, 2018 11:08 am

Re: Updated image available [2014-03-07]

Post by snav » Thu Jan 18, 2018 11:08 am

Cant someone post it somewhere?
I wanted to upgrade to the latest image but cant fint it anywhere

Post Reply