Automagically showing incorrect time

http://automagucally.weebly.com

Moderators: davka003, Telldus

Post Reply
misterleffe
Posts: 57
Joined: Thu Jan 18, 2018 11:08 am

Automagically showing incorrect time

Post by misterleffe » Thu Jan 18, 2018 11:08 am

My Automagically is a little strange ... Time showing is 1/2 hour behind local time (Swedish summertime). I've tried to shutdown the Raspberry, stop and start the Automagically service. Negative result in both cases.

My question is: From where is Raspberry/Automagically collecting the time? I have set the timezone to Europe/Stockholm and the long/lat for my location in the Automagically settings.

Anybody having a clue?



/misterleffe

antonholmstedt
Posts: 9
Joined: Thu Jan 18, 2018 11:08 am

Re: Automagically showing incorrect time

Post by antonholmstedt » Thu Jan 18, 2018 11:08 am

I'm having the same problem but two hours wrong, tried to fix it but can't and don't understand why. The developer doesn't seem to be very active here :)

antonholmstedt
Posts: 9
Joined: Thu Jan 18, 2018 11:08 am

Re: Automagically showing incorrect time

Post by antonholmstedt » Thu Jan 18, 2018 11:08 am

I've solved it now! Just add Google DNS IP:s to the list on your pi, then reboot.

misterleffe
Posts: 57
Joined: Thu Jan 18, 2018 11:08 am

Re: Automagically showing incorrect time

Post by misterleffe » Thu Jan 18, 2018 11:08 am

Ok, that's fine, but my Raspberry made the correction by it self after a few weeks. Seems very strange ...

Can you explain more in detail, where to put your solution. Should it be in Raspberry Pi or in Automagically?


/misterleffe

antonholmstedt
Posts: 9
Joined: Thu Jan 18, 2018 11:08 am

Re: Automagically showing incorrect time

Post by antonholmstedt » Thu Jan 18, 2018 11:08 am

The setting was made via ssh connection to the pi, the command to the right file is "sudo nano /etc/resolv.conf". I changed to Google's DNS, 8.8.8.8 and 8.8.4.4.

misterleffe
Posts: 57
Joined: Thu Jan 18, 2018 11:08 am

Re: Automagically showing incorrect time

Post by misterleffe » Thu Jan 18, 2018 11:08 am

Ok, I looked in the file and there was only 1 row:
nameserver 192.168.1.1

This is the IP of my gateway. Should I keep this row and add 8.8.8.8 and 8.8.4.4 in separate rows?
The file resolv.conf should be like this then:

nameserver 192.168.1.1
nameserver 8.8.8.8
nameserver 8.8.4.4


Is this correct??


/misterleffe

antonholmstedt
Posts: 9
Joined: Thu Jan 18, 2018 11:08 am

Re: Automagically showing incorrect time

Post by antonholmstedt » Thu Jan 18, 2018 11:08 am

You can delete the router IP.

Post Reply