Struggling to get local API working

Moderator: Telldus

Post Reply
joakimskog
Posts: 1
Joined: Sun Nov 11, 2018 9:27 am

Struggling to get local API working

Post by joakimskog » Fri Nov 30, 2018 8:41 am

I'm trying to get the local Api working on my TellStick ZNet Lite v2, which should be accessed by homebridge running on a Raspberry Pi.

The authorization works, and the token is generated, the config.json is validated, so it shouldn't be anything wrong with that. Still, when starting homebridge with the config.json usin the local api configuration, I get errors in the log (see below). I was hoping to get the local ID's, so I could finish the configuration of the config.json, but I only get the errors.

What's not working?

Code: Select all

homebridge_1  | Service "raspberrypi" (/etc/avahi/services/sftp-ssh.service) successfully established.
homebridge_1  | [11/27/2018, 7:06:54 PM] Loaded config.json with 0 accessories and 1 platforms.
homebridge_1  | [11/27/2018, 7:06:54 PM] ---
homebridge_1  | [11/27/2018, 7:06:54 PM] Loaded plugin: homebridge-dummy
homebridge_1  | [11/27/2018, 7:06:54 PM] Registering accessory 'homebridge-dummy.DummySwitch'
homebridge_1  | [11/27/2018, 7:06:54 PM] ---
homebridge_1  | [11/27/2018, 7:06:54 PM] Loaded plugin: homebridge-motion-fifo
homebridge_1  | [11/27/2018, 7:06:54 PM] Registering accessory 'homebridge-motion-fifo.MotionFifo'
homebridge_1  | [11/27/2018, 7:06:54 PM] ---
homebridge_1  | [11/27/2018, 7:06:54 PM] Loaded plugin: homebridge-samsungtv-control
homebridge_1  | [11/27/2018, 7:06:54 PM] Registering accessory 'homebridge-samsungtv.SamsungTV'
homebridge_1  | [11/27/2018, 7:06:54 PM] ---
homebridge_1  | [11/27/2018, 7:06:54 PM] Loaded plugin: homebridge-telldus
homebridge_1  | [11/27/2018, 7:06:54 PM] Registering platform 'homebridge-telldus.Telldus'
homebridge_1  | [11/27/2018, 7:06:54 PM] ---
homebridge_1  | [11/27/2018, 7:06:54 PM] Loading 1 platforms...
homebridge_1  | [11/27/2018, 7:06:54 PM] [Telldus Live!] Initializing Telldus platform...
homebridge_1  | [11/27/2018, 7:06:54 PM] [Telldus Live!] Loading accessories...
homebridge_1  | [11/27/2018, 7:06:54 PM] Loading 0 accessories...
homebridge_1  | [11/27/2018, 7:06:56 PM] [Telldus Live!] undefined
homebridge_1  | Unhandled rejection (<{"statusCode":401,"data":"{\"error\":\...>, no stack trace)
homebridge_1  | -U /homebridge -P /homebridge/node_modules -C

Post Reply