TellStick not found

Moderator: Telldus

isak
Posts: 17
Joined: Thu Jan 18, 2018 11:08 am

TellStick not found

Post by isak » Thu Jan 18, 2018 11:08 am

Hej.

Jag kör NexaHome (som anropar tdtool) på Ubuntu 9.10. Allting fungerar som det skall men jag får ett irriterande felmeddelande efter varje kommando som ser ut enligt nedan. Felmeddelandet kommer både när jag kör tdtool manuellt i konsollen och när NexaHome anropar tdtool.

Code: Select all

Turning on device 7, Kontoret - TellStick not found
Brytarna tänder och släcker som de skall, men felmeddelandet kommer ändå. Var skall jag börja felsöka?

/Anders

micke.prag
Site Admin
Posts: 2242
Joined: Thu Jan 18, 2018 11:08 am
Location: Lund
Contact:

Post by micke.prag » Thu Jan 18, 2018 11:08 am

Vilken batch av TellStick har du?
Micke Prag
Software
Telldus Technologies

isak
Posts: 17
Joined: Thu Jan 18, 2018 11:08 am

Post by isak » Thu Jan 18, 2018 11:08 am

batch 4 (en vit)

ral
Posts: 1
Joined: Thu Jan 18, 2018 11:08 am

Post by ral » Thu Jan 18, 2018 11:08 am

Hej,

Jag har samma problem som isak. Jag tror att felmeddelandet kom efter att jag hade uppdaterat Ubuntu från 8.4 till 9.10, det fungerade på den tidigare ver. av Ubuntu. Har batch 8 på TellStick.

granede
Posts: 18
Joined: Thu Jan 18, 2018 11:08 am
Location: Värmdö

Post by granede » Thu Jan 18, 2018 11:08 am

Har samma problem med Ubuntu 9.10. Fungerade i 9.04! Lamporna släcks och tänds men med meddelandet enligt ovan. UTOM vid allra första tdtool-anropet efter boot, då blir allt rätt.
Från anrop två och framåt alltid detta meddelande, dessutom tycker jag att det blir en viss fördröjning för lamporna att tändas och släckas, även om det som sagt ändå utförs.
Har testat med batch8!

micke.prag
Site Admin
Posts: 2242
Joined: Thu Jan 18, 2018 11:08 am
Location: Lund
Contact:

Post by micke.prag » Thu Jan 18, 2018 11:08 am

Vi håller på att kolla vad som är orsaken till detta. Tyvärr vet vi inte definitivt varför ännu.
Micke Prag
Software
Telldus Technologies

jonaz
Posts: 46
Joined: Thu Jan 18, 2018 11:08 am

Post by jonaz » Thu Jan 18, 2018 11:08 am

jag lider oxå av samma problem.... lite jobbit för mina högtalare i sovrummet sätts igång via tellsticken och kollar statusen med tdtool --list vilket gör att dom aldrig startar :S

edit: jag kör telldus-core_2.0.1-1_amd64.deb och får felmeddelande tex:

Turning off device 4, sovrumstereo2 - An error occurred when communication with TellStick

micke.prag
Site Admin
Posts: 2242
Joined: Thu Jan 18, 2018 11:08 am
Location: Lund
Contact:

Post by micke.prag » Thu Jan 18, 2018 11:08 am

Vi är medvetna om detta. Vi vet dock fortfarande inte varför.
Det uppkommer bara (hittils) i Ubuntu 9.10.
Vi har testat i andra distributioner med samma version på kärnan och där dyker felet inte upp.
Micke Prag
Software
Telldus Technologies

jonaz
Posts: 46
Joined: Thu Jan 18, 2018 11:08 am

Post by jonaz » Thu Jan 18, 2018 11:08 am

jag hittade något mer intressant. Om jag inte provade på några timmar och sedan försökte tända/släcka så funkade det EN gång.. innan meddelandet började komma igen

root@bulan:/usr/local/bin# tdtool --off 9
Turning off device 9, Tak kontor - Success
root@bulan:/usr/local/bin# tdtool --off 9
Turning off device 9, Tak kontor - An error occurred when communication with TellStick


Edit: jag är inte helt säker, men körde på egenkompilerad kärna 2.6.31.5 i ubuntu 9.10 i början och då fungerade tellstick fint.

det var när jag gick till default kärna 2.6.31-14-server som problemen kom.
Det kanske har med ubuntus säkerhetsgrejjor i kärnan tex apparmor?

isak
Posts: 17
Joined: Thu Jan 18, 2018 11:08 am

Post by isak » Thu Jan 18, 2018 11:08 am

Jag har också fått "success" någon gång. Den gången sätter jag det i samband med att jag körde flera kommandon snabbt efter varandra. Jag kör NexaHome, och klickade "släck" på alla lampor efter varandra. Den första hälften av lamporna stod det "success" på, den sista hälften hade felmeddelandet.

jonaz
Posts: 46
Joined: Thu Jan 18, 2018 11:08 am

Post by jonaz » Thu Jan 18, 2018 11:08 am

felet uppträder endast med ubuntu stock kernel 2.6.31-14-server (den jag testat)

jag har kompilerat 2.6.31.6 nu från kernel.org och nu funkar tellsticken fint


dvs de måste vara några av ubuntus patchar som pajjar de. Jag föreslår bugreport hos ubuntu efter mer noggran felsökning än vad jag gjort. Skrivt därefter länk till buggen här.

ran
Posts: 27
Joined: Thu Jan 18, 2018 11:08 am
Location: Linköping
Contact:

Post by ran » Thu Jan 18, 2018 11:08 am

Jag får felet "An error occurred when communication with TellStick" varje gång jag kör tdtool med Ubuntu 9.10 och 2.6.31-15 kernel.
Så den version är inte bättre än 2.6.31-14.
Det är aldrig försent att ge upp...

jonaz
Posts: 46
Joined: Thu Jan 18, 2018 11:08 am

Post by jonaz » Thu Jan 18, 2018 11:08 am

ran wrote:Jag får felet "An error occurred when communication with TellStick" varje gång jag kör tdtool med Ubuntu 9.10 och 2.6.31-15 kernel.
Så den version är inte bättre än 2.6.31-14.
japp det beror på att du kör senaste tdtool, gamla sa bara tellstick not found.
dra in 2.6.31.6 från kernel.org så är du fit to go :)

mbe002
Posts: 3
Joined: Thu Jan 18, 2018 11:08 am

fc12 har också problem

Post by mbe002 » Thu Jan 18, 2018 11:08 am

Verkar som om det inte bara är Ubuntu... har kärnan 2.6.31.5-127.fc12.i686.PAE och får samma problem.

isak
Posts: 17
Joined: Thu Jan 18, 2018 11:08 am

Post by isak » Thu Jan 18, 2018 11:08 am

Nu är mitt felmeddalnde borta i Ubuntu 9.10. Förmodligen försvann det i samband med någon uppdatering, men jag vet inte vilken. Jag såg att det låg en ny kärna i uppdateringarna för någon dag sedan.

De bästa felen är de som lagar sig själv!

Post Reply