LinuxMCE

Moderator: Telldus

Post Reply
permo
Posts: 1
Joined: Thu Jan 18, 2018 11:08 am

LinuxMCE

Post by permo » Thu Jan 18, 2018 11:08 am

Hej!

Jag tänkte göra ett försök med att fixa stöd i linuxmce för tellstick. Jag såg en tråd om det, men den verkar ha dött så jag postar en ny! Har någon redan lyckats? Jag skulle behöva lite hjälp, någon mer än jag som skulle ha glädje av detta?


/Per

Andy
Posts: 1
Joined: Thu Jan 18, 2018 11:08 am

LinxuMCE

Post by Andy » Thu Jan 18, 2018 11:08 am

Jag är super intresserad kör LMCE 8.10. Men har inte lyckats med tellstick.

rsafors
Posts: 8
Joined: Thu Jan 18, 2018 11:08 am

LinuxMCE

Post by rsafors » Thu Jan 18, 2018 11:08 am

Har försökt att installera drivrutinerna i kubuntu 7.10 och även i kubuntu 8.04 men jag saknar "libconfuse0". Har kompilerat och installerat denna manuellt men av någon anledning frågar telldus-core efter den ändå.
Jag har skapat en fråga på LinuxMCE forumet och om jag bara får in drivrutinerna så finns det tydligen en lösning för att ansluta Tellstick mot LMCE. (http://forum.linuxmce.org/ sök på Telldus)

GregB
Posts: 45
Joined: Thu Jan 18, 2018 11:08 am

Post by GregB » Thu Jan 18, 2018 11:08 am

Borde inte vara ngn skillnad mellan Kubuntu och Ubuntu... Har ni kikat här http://www.telldus.se/forum/viewtopic.php?t=331
Busenkelt att installera, precis som det SKA vara... funkade för mig på Ubuntu 8.04.

rsafors
Posts: 8
Joined: Thu Jan 18, 2018 11:08 am

LinuxMCE

Post by rsafors » Thu Jan 18, 2018 11:08 am

Japp det är busenkelt i Ubuntu men i Kubuntu saknas Libconfuse0. Har dock hittat den på http://packages.ubuntu.com/intrepid/i38 ... 0/download och efter installation av denna så går resten OK. Håller just nu på att ominstallera LMCE och sen får vi se om jag lyckas att integrera Tellstick med hjälp av DCEgen.

becke
Posts: 2
Joined: Thu Jan 18, 2018 11:08 am

Post by becke » Thu Jan 18, 2018 11:08 am

Reads with interest. Just managed to get my Tellstick working with Ubuntu 8.10 and cant wait to get it into LinuxMCE

becke
Posts: 2
Joined: Thu Jan 18, 2018 11:08 am

Svenska

Post by becke » Thu Jan 18, 2018 11:08 am

:D Hade läst ett annat forum just..

GabberPelle
Posts: 1
Joined: Thu Jan 18, 2018 11:08 am

Re: LinuxMCE

Post by GabberPelle » Thu Jan 18, 2018 11:08 am

Hallå alla, lite av min erfarenhet av LMCE och tellstick 1.0

Tellsticken är numera plug and play, dock behöver man lägga till repositoryn för telldus samt installlera telldus-core manuellt för att få det att fungera, men tellsticken hittas av LMCE och konfigureras automatiskt, behöver bara koppla den med en MD i något av era entertainment areas.

Sedan måste varje brytare konfigureras i /etc/telldus/tellstick.conf, med valfri texteditor:
sudo gedit /etc/telldus/tellstick.conf (om ni sitter i X på core'n eller ssh med -Y) alt. vim eller nano om ni ssh:ar, nano är nog enklast för nybörjare (måste dock först installeras med sudo apt-get install nano.

min /etc/telldus/tellstick.conf tex..:

deviceNode = "/dev/tellstick"
device {
id = 1
name = "Master Bedroom Table Lamp Right"
protocol = "arctech"
model = "codeswitch"
parameters {
house = "A"
unit = "1"
}
}

deviceNode = "/dev/tellstick"
device {
id = 2
name = "Master Bedroom Table Lamp Left"
protocol = "arctech"
model = "codeswitch"
parameters {
house = "A"
unit = "2"
}
}

deviceNode = "/dev/tellstick"
device {
id = 3
name = "Master Bedroom Window Lamp"
protocol = "arctech"
model = "codeswitch"
parameters {
house = "A"
unit = "3"
}
}

deviceNode = "/dev/tellstick"
device {
id = 3
name = "Master Bedroom Mirror Lamp"
protocol = "arctech"
model = "codeswitch"
parameters {
house = "A"
unit = "4"
}
}

deviceNode = "/dev/tellstick"
device {
id = 4
name = "Living Room Left Window"
protocol = "arctech"
model = "codeswitch"
parameters {
house = "B"
unit = "1"
}
}

osv..

kontrollera att det fungerar med tdtool.
tdtool --list :visar konfigurerade brytare.
tdtool -n 1 :startar brytare med id 1 från /etc/tellstick.conf
tdtool -f 1 :stänger

När ni fått en fungerande lista surfar ni till LMCE Admin: http://192.168.80.1/lmce-admin/
Wizard--> Devices --> Lights och börja lägga till motsvarande lista med id:na i Port/Channel Number rutan, tips är att vara så noga som möjligt när ni skriver descriptions. Blir jobbigt att särskillja i floorplan wizarden när man går över 3 brytare per rum, om man vill konfigurera cenarios och follow me funktionen..=P

Löst översatt från LMCE Wikin/ standard Ubuntu installation: http://wiki.linuxmce.org/index.php/Tellstick

Lägg till följande rad i /etc/apt/sources.list
deb http://download.telldus.com/debian/ stable main

Lägg till Nyckeln som vanligt:
wget -q http://download.telldus.se/debian/telldus-public.key -O- | sudo apt-key add -

Installera programmet:
sudo apt-get update
sudo apt-get install telldus-core


Hade inget problem med Libconfuse0? Vilken version körde du? Säker på att sudo apt-get update går igenom utan felmeddelande?
Behöver editera sources eftersom ubuntu har tagit bort sina 8.10 repos, byt ut archive överallt i /etc/apt/sources.list till old.releases.

från:
deb http://archive.ubuntu.com/ubuntu/ intrepid main
till:
deb http://old.releases.ubuntu.com/ubuntu/ intrepid main

http://wiki.linuxmce.org/index.php/Installation_Guide

Kör med det i senaste fungerande snapshot (LinuxMCE-8.10-24164-i386.iso) av LMCE 8.10 http://linuxmce.iptp.org/snapshots/. Alla som släpps är inte alltid helt fungerande och kan variera på hårdvara, kolla på hardware compability på wikin eller forum om ni har problem, följ guiden slaviskt: http://wiki.linuxmce.org/index.php/Installing_0810

Ställ gärna frågor om ni är mer nyfikna på Linux Media Center. Hjälper gärna om det kan få fler att komma igång och börja mecka med oss.
Hjälper mycket mot att mer hårdvara stöds om fler testar, bara att använda det och ge sin input till communityn hjälper bra mycket mer än man tror, mycket svårt att koda bort problem man inte stöter på och det flesta open sourcare har inte de fetaste bankonton att köpa allt som finns eller företag som stödjer dem,.,

Lycka till.

\P

Post Reply