Config av webserver?

Moderator: Telldus

Post Reply
Snoopy
Posts: 253
Joined: Thu Jan 18, 2018 11:08 am
Location: Kalmar
Contact:

Config av webserver?

Post by Snoopy » Thu Jan 18, 2018 11:08 am

Hallå!
Jag har just kommit in i detta med Nexa och webservern, har svårt att
fatta hur configurera. Kanske hela problemet ligger i mitt sätt att fixa
index.html. jag kör Apache på en XP, detta fungerar bra, jag kan surfa in
på hemsidan och se bilden av mitt hus med utplacerade lampor. Men
några symboler finns inte, bara de "?" som ersätter symbolerna. Klicka
på dem hjälper inte, servern hittar inte sidan.
Jag hämtade nyss NexaHome_1.5.2.jar som ersatte tidigare version.
Jaa har samma namn på enheterna i index-filen som i Nexahome.
Nexa home sköter sig bra, tänder/släcker enligt mina önskemål.

Ett frågetecken är variablerna i index-filen, t.ex:

Code: Select all

<input type=hidden name="cmd" value="#CMD#Kök (bord)#">
<input type=hidden name="psw" value="#PSW#">
<input type=hidden name="rnd" value="#RND#">
<input type=image title="Kök (bord)" alt="?" src="#IMAGE#Kök (bord)#">

hekj
Posts: 992
Joined: Thu Jan 18, 2018 11:08 am
Location: Stockholm
Contact:

Re: Config av webserver?

Post by hekj » Thu Jan 18, 2018 11:08 am

Snoopy wrote:Jag har just kommit in i detta med Nexa och webservern, har svårt att
fatta hur configurera. Kanske hela problemet ligger i mitt sätt att fixa
index.html. jag kör Apache på en XP, detta fungerar bra, jag kan surfa in
på hemsidan och se bilden av mitt hus med utplacerade lampor. Men
några symboler finns inte, bara de "?" som ersätter symbolerna. Klicka
på dem hjälper inte, servern hittar inte sidan.
Man ska inte använda sig av Apache eller IIS, webservern som behövs är redan inbyggd i NexaHome.
Snoopy wrote:Ett frågetecken är variablerna i index-filen, t.ex:

Code: Select all

<input type=hidden name="cmd" value="#CMD#Kök (bord)#">
<input type=hidden name="psw" value="#PSW#">
<input type=hidden name="rnd" value="#RND#">
<input type=image title="Kök (bord)" alt="?" src="#IMAGE#Kök (bord)#">
Manualen är väldigt kortfattad och beskrivningen av den inbyggda webservern är kanske inte helt komplett, ta inte illa upp men jag måste ändå fråga om du har läst den?
http://nexahome.se/manual/index.html#Topic44

/Henrik
Last edited by hekj on Sat Aug 18, 2012 11:55 am, edited 1 time in total.

Snoopy
Posts: 253
Joined: Thu Jan 18, 2018 11:08 am
Location: Kalmar
Contact:

Post by Snoopy » Thu Jan 18, 2018 11:08 am

Jepp! Har läst men inte fått igång den, därför Apache som alltid startar.

Jag har nu rensat registret i datorn, dödat serverprosessen, raderat .xml-filen och till slut startat om Nexahome.
Jag hittar hemsidan och kan påverka lamporna.
Men den grafiska bilden av huset hittar jag inte.
Path till sidorna är: C:\Nexahome\mywebserver
Jag får annan sida jag inte kan påverka eller hitta.
Ett steg framåt ändå! :D

(en timma senare)

Ok, har mekat lite till nu på fm. har hittat allt jag ska, båda hemsidorna
fungerar, standard och eget! :clap:
Hm, uppdateringen av sidan funkar inte.
[/code]<meta http-equiv="refresh" content="60;#URL#?mypage=demo&psw=#PSW#">

Snoopy
Posts: 253
Joined: Thu Jan 18, 2018 11:08 am
Location: Kalmar
Contact:

Post by Snoopy » Thu Jan 18, 2018 11:08 am

Ok, efter lite plockande fungerar allt som det var tänkt.

Återstår bara att streama video från en WVC200. :D

Post Reply