Fibaro Roller Shutter - Strange button behavior

Moderator: Telldus

Post Reply
Posts: 7
Joined: Thu Jan 18, 2018 11:08 am

Fibaro Roller Shutter - Strange button behavior

Post by AndreasB » Fri Dec 11, 2020 11:08 pm


I already have my solution but am posting this to help others. My assumption is that this is a general problem with the FGR-223 and not related to Tellstick, but who knows. I was also too lazy to create a fibaro account....

I installed a Fibaro Roller Shutter 3 (FGR-223) with two momentary push buttons to control an awning (markis). I use a Znet Lite v1 as controller and used the Telldus Live page in all tests (no lua scripting)

After installation and automatic calibration, the manual stated that one button (S1) should make the awning go down and the other (S2) make it go up. But instead S1 had a toggling function so that every second press made it go down and up respectively. S2 only had the funtion to stop a moving motor (which could also be done with S1, so S2 was superflous)

I tried setting different configuration parameters, including writing parameter 20=0 (0="momentary push buttons", which is supposed to be the default).

What solved the issue for me was to first write parameter 20=2( 2="single, momentary swich button") and then write parameter 20=0

Interestingly, with parameter 20=2, the behavior was not exactly the same as the initial one, since S2 no longer had any function. So it was not simply a problem of incorrect default value of parameter 20. Unfortunately the Telldus Live page doesn't support reading config parameters so I couldn't see the initial values.

I hope that this may help someone else.

Post Reply