Schemaläggning av händelser fungerar inte

http://karpero.mine.nu/ha

Moderators: tom_rosenback, Daniel, Telldus

Post Reply
planetburner
Posts: 2
Joined: Thu Jan 18, 2018 11:08 am

Schemaläggning av händelser fungerar inte

Post by planetburner » Thu Jan 18, 2018 11:08 am

Hej! Jag har installerat och konfigurerat (som debian/raspian-novis ska tilläggas) HomeAutomation på en RPI2. Efter lite pill har jag fått in temperatursensorer som uppdateras ordentligt (via crontab/parser) och manuell styrning av ett par Nexaswitchar. Men jag stöter på patrull när jag försöker schemalägga händelser (av/på [satt tid] i det här fallet), det händer helt enkelt inget.
Jag har försökt läsa mig till proper konfigurering men vet inte riktigt var jag ska börja felsöka. PHP verkar köra med rätt tid- och datuminställningar och eftersom manuella styrningen samt sensoruppdatering fungerar verkar PHP/Apache ha rättigheter att använda tdtool. Den misstanke jag har just nu är att det har med vilken user som har rätt att skapa crontabs (jag kör parsern från den globala crontaben), men det kanske är ett villospår?

Anyhows, jag tänkte att det kanske är någon här som har stött på samma problem och vet hur jag får igång schemaläggningen?

Mvh, Rickard

tom_rosenback
Posts: 778
Joined: Thu Jan 18, 2018 11:08 am
Contact:

Re: Schemaläggning av händelser fungerar inte

Post by tom_rosenback » Thu Jan 18, 2018 11:08 am

Kolla så att www-data (brukar vara den användaren på dom flesta *nix system inte finns med i varken at.deny och cron.deny filerna samt att .allow filerna är rätt konfigurerade. AT daemonen (atd) måste också vara igång.
//Tom

Senaste info och release om/av HomeAutomation hittas här http://karpero.mine.nu/ha
Latest info and release of HomeAutomation can be found here http://karpero.mine.nu/ha

planetburner
Posts: 2
Joined: Thu Jan 18, 2018 11:08 am

Re: Schemaläggning av händelser fungerar inte

Post by planetburner » Thu Jan 18, 2018 11:08 am

Sweet, tänkte inte på AT deamon också hade med saker att göra, at.deny hade www-data i listan. Nu fungerar det fint. Tack för hjälpen!

Post Reply