Ev. bugg i NexaHome 4.0.1

Moderators: hekj, Telldus

Post Reply
Wicket
Posts: 15
Joined: Thu Jan 18, 2018 11:08 am

Ev. bugg i NexaHome 4.0.1

Post by Wicket » Thu Jan 18, 2018 11:08 am

Undrar om jag råkat ut för en bugg, eller om det är nått annat som strular.

Jag har laddat ner 4.0.1 och startar det manuellt från terminalen på min rpi.
När jag startar det, så aktiveras den sista enheten i min lista automatiskt?
(vilket inte vore hela världen, men problemet är att jag har kaffebryggaren inkopplad på den pluggen) :)

Så här ser konsoll-loggen ut efter ett par minuter
*****************************************************************
2015-11-12 17:32:33 java.home (/opt/jdk1.8.0_51/jre)
2015-11-12 17:32:33 Starting event processing...
2015-11-12 17:32:33 2015-11-13 16:59 ON dmy-57 (event: 16)
2015-11-12 17:32:33 Up and running...
2015-11-12 17:32:33 java version "1.8.0_51"
Java(TM) SE Runtime Environment (build 1.8.0_51-b07)
Java HotSpot(TM) Client VM (build 25.51-b07, mixed mode)
2015-11-12 17:32:34 Script executed (start.bsh), result: [[timer, save_temp:60]]
2015-11-12 17:32:45 RaZberry by Z-Wave.Me (v2.1.1, 2015-09-02 15:34:21 +0300)
2015-11-12 17:32:45 Script executed (200.bsh), result: [[echo, Startar kaffebryggaren], [timer, coffee_timer:4800]]
2015-11-12 17:33:34 Script executed (save_temp.bsh), result: [[timer, save_temp:60]]
2015-11-12 17:34:34 Script executed (save_temp.bsh), result: [[timer, save_temp:60]]
2015-11-12 17:35:34 Script executed (save_temp.bsh), result: [[timer, save_temp:60]]
*****************************************************************

om jag stänger ner 4.0.1 och startar 4.0.0, så uppstår inte problemet :?

Silversurfaren
Posts: 9
Joined: Thu Jan 18, 2018 11:08 am
Location: Linköping

Re: Ev. bugg i NexaHome 4.0.1

Post by Silversurfaren » Thu Jan 18, 2018 11:08 am

Jag har råkat ut för att ett 'Devices' med 'Function' satt till 'Sunlight' inte finns med bland alla andra schemalagda enheter i 4.0.1. Den bara försvinner från listan (Queue) när jag startar upp 4.0.1 men den finns fortfarande kvar i 'Devices' (tänder och släcker följdaktligen då inte heller). Vid återgång till 4.0.0 så finns den åter med i listan (Queue) och allt fungerar som vanligt.

Nu har jag ändrat konfigurationen till att använda 'Function' under 'Events' och istället 'Sunrise -' respektive 'Sunset +' och då uppstår inte det här fenomenet i 4.0.1 utan allt verkar fungera precis som i 4.0.0.

hekj
Posts: 992
Joined: Thu Jan 18, 2018 11:08 am
Location: Stockholm
Contact:

Re: Ev. bugg i NexaHome 4.0.1

Post by hekj » Thu Jan 18, 2018 11:08 am

Silversurfaren wrote:Jag har råkat ut för att ett 'Devices' med 'Function' satt till 'Sunlight' inte finns med bland alla andra schemalagda enheter i 4.0.1. Den bara försvinner från listan (Queue) när jag startar upp 4.0.1 men den finns fortfarande kvar i 'Devices' (tänder och släcker följdaktligen då inte heller). Vid återgång till 4.0.0 så finns den åter med i listan (Queue) och allt fungerar som vanligt.

Nu har jag ändrat konfigurationen till att använda 'Function' under 'Events' och istället 'Sunrise -' respektive 'Sunset +' och då uppstår inte det här fenomenet i 4.0.1 utan allt verkar fungera precis som i 4.0.0.
Jag kan bekräfta att det finns en "Sunlight" bugg i version 4.0.1, har lagt upp en ny version som jag hoppas ska fungera.

Silversurfaren
Posts: 9
Joined: Thu Jan 18, 2018 11:08 am
Location: Linköping

Re: Ev. bugg i NexaHome 4.0.1

Post by Silversurfaren » Thu Jan 18, 2018 11:08 am

Jag har ändrat tillbaka till den konfiguration som jag hade i 4.0.0 (med 'Sunlight') och kör den nu i 4.0.3 och det ser ut att fungera som tidigare :)

Snabbt jobbat :D

Post Reply