Dålig tillgång till WEB servern på Android

Moderators: hekj, Telldus

Post Reply
PontusBC
Posts: 28
Joined: Thu Jan 18, 2018 11:08 am

Dålig tillgång till WEB servern på Android

Post by PontusBC » Thu Jan 18, 2018 11:08 am

Hej, jag sedan en tid tillbaka (tror att det var i samband med uppdateringen av programvaran i telefonen) märkt att när jag ansluter till nexahome webservern så uppdateras inte alla bilder alltid på telefon. Jag har ett 20-tal bilder på min sida och oftast är det så att bakgrunden inte ändras till svart utan förblir vit samt att någon ikon (knapp) blir en ruta med kryss i. Detta händer på min telefon oavsett om jag går in via appen eller webläsaren. Är ganska säker på att det har med telefonen att göra då detta aldrig sker på IPhone, Ipad, Macbooken eller någon annan dator. Telefonen är en HTC One med Android 4.2.2 och HTC Sense 5.0.
Är detta något som någon vet en lösning på, kan man typ få telefonen (appen) att buffra bilderna eftersom samma återkommer hela tiden vid uppdatering efter att ett kommando utförts?

Claes66
Posts: 7
Joined: Thu Jan 18, 2018 11:08 am

Re: Dålig tillgång till WEB servern på Android

Post by Claes66 » Thu Jan 18, 2018 11:08 am

Hej
Jag vet inte om det är samma felorsak i grunden men jag har problem med att bilder inte laddas när jag kör utanför mitt lokala nätverk (alltså via mobilt nätverk). Om jag kar kopplat upp min telefon, som råkar vara en HTC One (har andra fabrikat samma symtom) hemma via wifi så är det inga problem och standard sidan i nexahome med alla brytare fungerar och alla ikoner bilder laddas utan problem. Om jag istället kopplar upp mig utifrån (ja jag har gjort port forwarding :D ) så inträffar det att sidan laddar men samtidigt så kommer det upp en ruta med texten "on.mini.png" och ett timglas samt bakgrunden är dimmad och här står den ca 1,5 min.
Efter detta så blir barkunden ok men utan alla status bilderna laddats och du kan tända och släcka lampor utan problem med den enda bieffekten att efter varje tryck på en knapp inträffar samma ovan omnämnda delay. Jag är ganska säker på att det inte varit så här tidigare men jag vet inte när jag såg detta första gången och jag har uppdaterat både nexahome (3.7.0) och raspberryns os till Debian Linux 7.4 med utgångspunkt från dem image som finns i detta forum .
http://nexahome.se/rpi/2013-09-25-wheez ... -swe-v1.7z

PontusBC
Posts: 28
Joined: Thu Jan 18, 2018 11:08 am

Re: Dålig tillgång till WEB servern på Android

Post by PontusBC » Thu Jan 18, 2018 11:08 am

Hej, jag bör väl nämna att för händer detta både när jag är lokalt eller inte dock så är det färre bilder som har problem när man är inloggad lokalt. Kan man få dessa Nexahome appen att buffra bilderna lokalt på telefonen då det alltid är samma uppsättning bilder som används? Tror att detta skulle göra livet mycket mer trivsamt användar synpunkt.

hekj
Posts: 991
Joined: Thu Jan 18, 2018 11:08 am
Location: Stockholm
Contact:

Re: Dålig tillgång till WEB servern på Android

Post by hekj » Thu Jan 18, 2018 11:08 am

PontusBC wrote:Hej, jag bör väl nämna att för händer detta både när jag är lokalt eller inte dock så är det färre bilder som har problem när man är inloggad lokalt. Kan man få dessa Nexahome appen att buffra bilderna lokalt på telefonen då det alltid är samma uppsättning bilder som används? Tror att detta skulle göra livet mycket mer trivsamt användar synpunkt.
Kollar om det går att få till någon slags buffring av bilderna i appen, återkommer...

hekj
Posts: 991
Joined: Thu Jan 18, 2018 11:08 am
Location: Stockholm
Contact:

Re: Dålig tillgång till WEB servern på Android

Post by hekj » Thu Jan 18, 2018 11:08 am

Nu har jag gjort det möjligt för webläsare att buffra bilderna, NexaHome v3.7.5 finns att hämta på nexahome.se

Claes66
Posts: 7
Joined: Thu Jan 18, 2018 11:08 am

Re: Dålig tillgång till WEB servern på Android

Post by Claes66 » Thu Jan 18, 2018 11:08 am

Hej
Har nu testat NexaHome v3.7.5 på ,in Raspberry Pi + den uppdaterade Android appen som kom idag på Google play och nu fungerar allt utan tidigare problem som beskrivits av mig i denna tråd tidigare :lol:
Tack Henrik för snabb återkoppling och åtgärd av detta problem, du är grym!!!

Post Reply