TelldusCenter 2.1.1 Beta

Moderator: Telldus

stefan.persson
Posts: 353
Joined: Thu Jan 18, 2018 11:08 am

TelldusCenter 2.1.1 Beta

Post by stefan.persson » Thu Jan 18, 2018 11:08 am

The beta for TelldusCenter 2.1.1 is here!

Please note that this is beta software. That means that there are some already known bugs that we are working on, and most probably there are some bugs that are not known yet, and that we hope to find with your help!

The greatest changes are (with resolved ticket number, details can be found at http://developer.telldus.com/ticket/<ticketnumber>):
+ Sensor data available in TelldusCenter and tdtool (#96, #122)
+ Support for UPM temperature and humidity sensors (#103)
+ Support for Oregon 0x1A2D (#144)
+ Possible not to wait for confirmation from TellStick after a command has been sent (#98)
+ Telldus Live! can be activated from the Settings menu too (#101)
+ Better debug and error messages from TelldusService and tdtool (#103, #146)
- Fixed several stability issues, and try to reconnect if communication with TellStick is lost (#92, #93, #94, #95, #102, #125, #126, #127, #132, #145)
- Fixed bug in IKEA protocol (#81)
- Improved filtering when scanning remotes (#88)
- Fixed TelldusCenter/Telldus Live! reconnection issues (#117, #133, #151)

Since there have been a lot of stability issues on Windows, we are releasing the Windows beta first, to allow for a longer test period. We'll continue with other platforms in the upcoming days.

You can download TelldusCenter 2.1.1 Beta here:
http://download.telldus.com/TellStick/S ... _beta1.exe

It's recommended to upgrade your firmware at the same time, for all functions to work (new protocols in TellStick Duo, more reliable communication between TellStick/TellStick Duo and TelldusService). Do this by running TellStickFlasher located in the Telldus installation folder. Stop TelldusService before upgrading the firmware, see instructions here: http://developer.telldus.com/wiki/Firmware.
Please note that pre-production TellStick Duo is not compatible with the new firmware.

We also have a beta firmware for TellStick Net. This firmware contains support for additional protocols (see the roadmap for details, http://developer.telldus.com/query?stat ... tone=2.1.1 ), and TellStick Net is now better at detecting when it has been disconnected from the server due to network problems. Commands sent to TellStick Net are now acknowledged, and no new commands are sent until they last one is confirmed. It will instead be queued at the server, and is not lost if the buffer in TellStick Net is full, which could happen before.
The TellStick Net firmware is here: http://download.telldus.com/TellStick/S ... lasher.zip

Known issues: (more things will be added here, as soon as you find them)
Design improvements (#165, #166, #168)
Issues with sensor listing in tdtool (#164)
Cannot reconnect to TellStick after computer has been in sleep mode, Windows
Some temperature sensor is not received any longer - Regression issue, need raw input from that sensor to compare

When you encounter any bugs or other issues, please post a ticket in our bug tracking system, http://developer.telldus.com (you have to login first to report new tickets). You can also just report it in this thread, but it's easier for us if you post a ticket.

Enjoy!

/Team Telldus
Stefan Persson
Software
Telldus Technologies

rhoddas
Posts: 65
Joined: Thu Jan 18, 2018 11:08 am

Re: TelldusCenter 2.1.1 Beta

Post by rhoddas » Thu Jan 18, 2018 11:08 am

Hi!

Great with a new driver!

I have updated my tellstick and tellstick duo to latest firmware and also the beta driver

I just wondering about the driver date in windows device manager. See attached file

//Peter
Attachments
Capture.PNG
Capture.PNG (15.97 KiB) Viewed 24143 times

krambriw
Posts: 654
Joined: Thu Jan 18, 2018 11:08 am

Re: TelldusCenter 2.1.1 Beta

Post by krambriw » Thu Jan 18, 2018 11:08 am

I have one of the first developer Duo and I am not able to upgrade the firmware. The upgrade finds the Duo but then hangs at "Entering bootloader"

Tried in two different PC's (one with XP, one with Vista)

Reboot did not help

Best regards, Walter
Image1.png
Image1.png (30.48 KiB) Viewed 24125 times
Image2.png
Image2.png (31.89 KiB) Viewed 24125 times

micke.prag
Site Admin
Posts: 2242
Joined: Thu Jan 18, 2018 11:08 am
Location: Lund
Contact:

Re: TelldusCenter 2.1.1 Beta

Post by micke.prag » Thu Jan 18, 2018 11:08 am

@krambriw: Sorry, forgot to mention. Preproduction TellStick Duo is not compatible with the firmware upgrade. The hardware differs between the versions. We can modify yours if you want. Please create a support request if you are interested in this.
Micke Prag
Software
Telldus Technologies

Mäg
Posts: 5
Joined: Thu Jan 18, 2018 11:08 am

Re: TelldusCenter 2.1.1 Beta

Post by Mäg » Thu Jan 18, 2018 11:08 am

Hi there!

Lets try to explain this in english...

I've been using a tellstick duo with switchking and eventghost and was before I installed this beta able to recieve sensor values from one of my two oregon temp sensors (THN132N). The one that was working was modell EA4C code 158. The other one I obviously dont know.
Server is Win7 x64.

After the beta update I can see the Tellstick duo flash at the same time as both the temp sensors LED blinks alltough nothing gets reported in neither switchking nor eventghost. I also checked in Telldus center, no sign of them there.
So the Tellstick Duo seems to get the signal from both sensors but nothing gets forwarded to the program?

So far Ive tried reseting them, moved them closer, rebooted server, unplugged and replugged tellstick, waited 2h (didnt have to wait last time).
The Tellstick Duo recieves signals from a Nexa remote and outputs them in switchking/eventghost (but not as a sensor in Telldus Center)
Will now also try to install the beta on another computer to get a clean install.

Im guessing this is a bug caused by some change in the code.

Let me know if I could provide any more feedback, screenshots?

Marten0615
Posts: 14
Joined: Thu Jan 18, 2018 11:08 am

Re: TelldusCenter 2.1.1 Beta

Post by Marten0615 » Thu Jan 18, 2018 11:08 am

micke.prag wrote:@krambriw: Sorry, forgot to mention. Preproduction TellStick Duo is not compatible with the firmware upgrade. The hardware differs between the versions. We can modify yours if you want. Please create a support request if you are interested in this.
I am exited!

How about Tellstick Net PP? :) I dont have a manual but I guess that firmware update on retail models is done though usb connection. It looks like soldering a usb port to the board could be possible, if hardware and software supports it?

My unit runs software "TellStick Net v1" at the moment

//Mårten

gein
Posts: 437
Joined: Thu Jan 18, 2018 11:08 am

Re: TelldusCenter 2.1.1 Beta

Post by gein » Thu Jan 18, 2018 11:08 am

Wow. I ran the TellstickNetFlasher on Ubuntu using Wine and "it just worked"! The flash procedure is somewhat magical as well as you don't have to provide any information at all. But according to live.telldus.com my Net device now runs v3. And now my Clas Ohlson thermometer show. Great work!

edit/ hmm, the older Viking thermometer that previously wasn't found seems to show up as well, is that expected?
edit/ I was wrong, it's not that thermometer showing up. It's another sensor which I'm not sure where it is ;)
edit/ Ah, it seems to be the one that previously reported 255% on humidity. The Net does not seem to receive anything from that device anymore, instead a new one has showed up which doesn't have humidity presented at all.

tronde
Posts: 593
Joined: Thu Jan 18, 2018 11:08 am

Re: TelldusCenter 2.1.1 Beta

Post by tronde » Thu Jan 18, 2018 11:08 am

gein wrote:Wow. I ran the TellstickNetFlasher on Ubuntu using Wine and "it just worked"! The flash procedure is somewhat magical as well as you don't have to provide any information at all. But according to live.telldus.com my Net device now runs v3. And now my Clas Ohlson thermometer show. Great work!

edit/ hmm, the older Viking thermometer that previously wasn't found seems to show up as well, is that expected?
edit/ I was wrong, it's not that thermometer showing up. It's another sensor which I'm not sure where it is ;)
edit/ Ah, it seems to be the one that previously reported 255% on humidity. The Net does not seem to receive anything from that device anymore, instead a new one has showed up which doesn't have humidity presented at all.
Agree with the magic feeling. Great work.

You will find that the new and old Viking shares the same unit ID.

My Net does also read the Clas Ohlson unit, but the update frequency seems veeery slow?

gein
Posts: 437
Joined: Thu Jan 18, 2018 11:08 am

Re: TelldusCenter 2.1.1 Beta

Post by gein » Thu Jan 18, 2018 11:08 am

tronde wrote:My Net does also read the Clas Ohlson unit, but the update frequency seems veeery slow?
Mine seems to be every 3 minutes.

micke.prag
Site Admin
Posts: 2242
Joined: Thu Jan 18, 2018 11:08 am
Location: Lund
Contact:

Re: TelldusCenter 2.1.1 Beta

Post by micke.prag » Thu Jan 18, 2018 11:08 am

@Mäg: Strange. Maybe we sort them out since we now calculate using a checksum. We should probably find a way to get the raw output from the TellStick Duo so we can manually decode the data and see what is wrong.

@Marten0615: TellStick Net PP i compatible with the new firmware. You update it on the network. Just make sure your computer is connected to the same netword as your TellStick Net and run the flasher utility.

@gein: Yes, we are now trying to filter out the sensors not sending humidity. I don't know why it shows up as a new sensor. What is the old and new id for the sensors?
Micke Prag
Software
Telldus Technologies

gein
Posts: 437
Joined: Thu Jan 18, 2018 11:08 am

Re: TelldusCenter 2.1.1 Beta

Post by gein » Thu Jan 18, 2018 11:08 am

micke.prag wrote:@gein: Yes, we are now trying to filter out the sensors not sending humidity. I don't know why it shows up as a new sensor. What is the old and new id for the sensors?
Old: 2928, New: 9685

Mäg
Posts: 5
Joined: Thu Jan 18, 2018 11:08 am

Re: TelldusCenter 2.1.1 Beta

Post by Mäg » Thu Jan 18, 2018 11:08 am

I tried installing the telldus beta on another computer and had the same issues.
Then i tried downgrading to the old version that was working. Still no temperature sensor.

So its probably the firmware change thats causing this. I upgraded to firmware 5 yesterday.
Is it possible to downgrade the firmware on the tellstick duo? If so I could try that if you send me the firmware file (had firmware 4).

Of course it could be that the before working sensor has broken, but it seems unlikely. After all I can see it blink and the tellsticks led flash at the same time.

Marten0615
Posts: 14
Joined: Thu Jan 18, 2018 11:08 am

Re: TelldusCenter 2.1.1 Beta

Post by Marten0615 » Thu Jan 18, 2018 11:08 am

micke.prag wrote:@Marten0615: TellStick Net PP i compatible with the new firmware. You update it on the network. Just make sure your computer is connected to the same netword as your TellStick Net and run the flasher utility.
Maby I'm stupid but I think that I have covered all steps as described in this post and on your wiki and so far I have been unsucessful with establishing contact between the updating software and my net pp through ethernet connection. The tellstick net PP operates normaly with its version 1 and Live!. If i try to delete location i live, as soon as I log in to my Live! a banner comes up that it tries to connect with my live account again. And connectiong works perfect.
I have tried doing these following steps both with the net pp connected and disconneced in the Live! service.

I have tried several combinations but have not been able to establish a connection. My main network is a stock settings linux based router (m0n0wall) with gigabit switches and a Dlink dir 655 (with dhcp and firewall turned off) set up as an access point. Some of my devices have static ip. Could static ip adresses be an issue if they all are in the same subnet eg. 192.168.0.xxx?

The two computers i have tested with both runs Windows 7. I have tested to turn off both my avast anti virus and windows firewall. First i tried with my laptop connected wireless but I have also tested both my laptop and another machine connected with network cable to the same switch and to my router for internet access. I have installed the windows software as desribed in readme "vcredist_x86" and the telldusnetflasher. I have also tested to install telldus center and to inactivate the service. But i guess that telldus center is not needed for this to work? Should the tellstick net be activated in live, removed or does it not matter?

I took an old zyxel router (mainly to exclude problems with my regular network) with stock settings (with dhcp, no static adresses) and connected my computer and the tellstick net pp with ethernet cables to it. They connect like usual and telldus Live finds the device directly when I login, but the telldusnetflasher does not find this unit. I tested this combination without internet access to this router, no difference.

I read about an "unbricking strategy" on the wiki, does that strategy work when unit isn't bricked? :) Or could it be an identification issue, being a pp and therefore not recogniced correctly in the updating software, (or is the harware identical accept for the differance between usb/dc jack)?

Mayby i should start writing in Swedish instead, I guess that there is currently 0 users that does not speek swedish and own a pp model and therefore could have use of reading this ? :)

MVH Mårten

micke.prag
Site Admin
Posts: 2242
Joined: Thu Jan 18, 2018 11:08 am
Location: Lund
Contact:

Re: TelldusCenter 2.1.1 Beta

Post by micke.prag » Thu Jan 18, 2018 11:08 am

Wow, Marten0615. What an error report. What if everybody was as thorough as you!
I just remember that you probably have a too early firmware without support for the automatic upgrading using the utility. Please send me an email and I will explain how you can upgrade the firmware manually. You need the ip-address of your device.
Micke Prag
Software
Telldus Technologies

redina
Posts: 3
Joined: Thu Jan 18, 2018 11:08 am

Re: TelldusCenter 2.1.1 Beta

Post by redina » Thu Jan 18, 2018 11:08 am

Mäg wrote: I've been using a tellstick duo with switchking and eventghost and was before I installed this beta able to recieve sensor values from one of my two oregon temp sensors (THN132N). The one that was working was modell EA4C code 158. The other one I obviously dont know.
Server is Win7 x64.
I also have problem with http://www.brc.se/vaderelektronik/orego ... 801-vader/ Oregon temp sensor (RAR801) after the update. Before it worked. I also have an temp sensor from TeknikMagasinet (Fineoffset, temperatur).

Telldus beta and new firmware.
Server is Win7 x64.

Post Reply