new ubuntu package broken?

Moderator: Telldus

Post Reply
jonaz
Posts: 46
Joined: Thu Jan 18, 2018 11:08 am

new ubuntu package broken?

Post by jonaz » Thu Jan 18, 2018 11:08 am

Im running ubuntu 10.04 LTS and got this when i tried to upgrade:

root@bulan:~# aptitude dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
telldus-core
1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 114kB of archives. After unpacking 20.5kB will be used.
The following packages have unmet dependencies:
telldus-core: Depends: libftdi1 (>= 0.18) but 0.17-1 is installed.
The following actions will resolve these dependencies:

Remove the following packages:
telldus-core

Score is 121

Accept this solution? [Y/n/q/?] ^C

stefan.persson
Posts: 353
Joined: Thu Jan 18, 2018 11:08 am

Re: new ubuntu package broken?

Post by stefan.persson » Thu Jan 18, 2018 11:08 am

The package is now rebuilt with libftdi1 0.17 instead of 0.18, and it should work in the latest Ubuntu LTS.
Stefan Persson
Software
Telldus Technologies

jonaz
Posts: 46
Joined: Thu Jan 18, 2018 11:08 am

Re: new ubuntu package broken?

Post by jonaz » Thu Jan 18, 2018 11:08 am

Thanks! works fine now! :)

HaunsTM
Posts: 5
Joined: Thu Jan 18, 2018 11:08 am

Re: new ubuntu package broken?

Post by HaunsTM » Thu Jan 18, 2018 11:08 am

Hi!

Sorry if I send to a closed topic or posting in the wrong forum but I do not really know where to turn.

My problem is about the same as "jonaz" above (I think). Even if if the solution above worked for him, it really doesn't for me. Maybe we don't have the same issue?

First of all, I'm a complete beginner in Ubuntu (I'm a Windows 7 64 bit user usually). I have version 10.04.3 LTS

Code: Select all

cat / etc / issue
I have followed the installation guide for GUI installation: http://developer.telldus.com/wiki/TellS ... tionUbuntu.

The error message I get is (in a dialog box):
Could not mark all the packages for installation or upgrade

The following packages have unresolvable dependencies. Make sure that all required repositories are added and enabled in the preferences.

telldus-core:
Depends: libftdi1 (> = 0.18) but 0.17-1 is to be installed


Close



This is my complete sources.list

Code: Select all

sudo gedit / etc / apt / sources.list

Code: Select all

################################################## ###########
################### OFFICIAL UBUNTU REPO ###################
################################################## ###########

###### Ubuntu Main Repos
deb http://se.archive.ubuntu.com/ubuntu/ hardy main universe

###### Ubuntu Update Repos
deb http://se.archive.ubuntu.com/ubuntu/ jaunty-security main universe
deb http://se.archive.ubuntu.com/ubuntu/ jaunty-updates main universe

###### Ubuntu Partner Repo
deb http://archive.canonical.com/ubuntu jaunty partner

deb http://ports.ubuntu.com/ubuntu-ports/ jaunty main universe restricted multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ jaunty main universe restricted multiverse # Added by software-properties
deb http://ports.ubuntu.com/ubuntu-ports/ jaunty-security universe main multiverse restricted
deb-src http://ports.ubuntu.com/ubuntu-ports/ jaunty-security universe main multiverse restricted
deb http://ports.ubuntu.com/ubuntu-ports/ jaunty-updates universe main multiverse restricted
deb-src http://ports.ubuntu.com/ubuntu-ports/ jaunty-updates universe main multiverse restricted
deb http://ports.ubuntu.com/ubuntu-ports/ hardy-proposed universe main multiverse restricted
deb-src http://ports.ubuntu.com/ubuntu-ports/ hardy-proposed universe main multiverse restricted
deb http://ports.ubuntu.com/ubuntu-ports/ intrepid-backports universe main multiverse restricted
deb-src http://ports.ubuntu.com/ubuntu-ports/ intrepid-backports universe main multiverse restricted
deb http://download.telldus.com/debian/ stable main

I have also tried to manually update the repository

Code: Select all

sudo apt-get update
but my problem still exists. Exactly the same error dialog show up.

Can somebody help me please? What am I doing wrong?

stefan.persson
Posts: 353
Joined: Thu Jan 18, 2018 11:08 am

Re: new ubuntu package broken?

Post by stefan.persson » Thu Jan 18, 2018 11:08 am

I can't find anything odd in the things you post. Could you please run the command

Code: Select all

apt-cache showpkg telldus-core
and post the output here?
Stefan Persson
Software
Telldus Technologies

HaunsTM
Posts: 5
Joined: Thu Jan 18, 2018 11:08 am

Re: new ubuntu package broken?

Post by HaunsTM » Thu Jan 18, 2018 11:08 am

Thank you very much for your answer Stefan!

This is the output when I run that command:

Code: Select all

ubuntu@D2Plug:~$ apt-cache showpkg telldus-core
Package: telldus-core
Versions: 
2.1.0-1 (/var/lib/apt/lists/download.telldus.com_debian_dists_stable_main_binary-armel_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/download.telldus.com_debian_dists_stable_main_binary-armel_Packages
                  MD5: d2e2b22b1f875c2073be98b92668b379


Reverse Depends: 
  libtelldus-core2,telldus-core 2.1.0-1
Dependencies: 
2.1.0-1 - libc6 (2 2.4) libconfuse0 (2 2.5) libftdi1 (2 0.18) libgcc1 (2 1:4.4.0) libstdc++6 (2 4.4.0) libtelldus-core2 (2 2.1.0) 
Provides: 
2.1.0-1 - 
Reverse Provides: 
ubuntu@D2Plug:~$ 
And just in case, this is my system:

Code: Select all

ubuntu@D2Plug:~$ sudo lshw
d2plug                    
    description: Computer
    width: 32 bits
  *-core
       description: Motherboard
       physical id: 0
     *-memory
          description: System memory
          physical id: 0
          size: 880MiB
     *-cpu
          physical id: 1
          bus info: cpu@0
          size: 800MHz
          capacity: 800MHz
          capabilities: cpufreq
     *-scsi
          physical id: 2
          bus info: usb@1:1.1
          logical name: scsi1
          capabilities: emulated
        *-disk:0
             description: SCSI Disk
             product: STORAGE DEVICE
             vendor: Generic
             physical id: 0.0.0
             bus info: scsi@1:0.0.0
             logical name: /dev/sda
             version: 9910
             capabilities: removable
           *-medium
                physical id: 0
                logical name: /dev/sda
        *-disk:1
             description: SCSI Disk
             product: STORAGE DEVICE
             vendor: Generic
             physical id: 0.0.1
             bus info: scsi@1:0.0.1
             logical name: /dev/sdb
             version: 9910
             capabilities: removable
           *-medium
                physical id: 0
                logical name: /dev/sdb
  *-network:0
       description: Ethernet interface
       physical id: 1
       logical name: eth1
       serial: f0:ad:4e:00:c3:ad
       size: 100MB/s
       capacity: 1GB/s
       capabilities: ethernet physical tp aui bnc mii fibre 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=mv643xx_eth driverversion=1.4 duplex=full firmware=N/A ip=192.168.0.189 link=yes multicast=yes port=MII speed=100MB/s
  *-network:1
       description: Wireless interface
       physical id: 2
       logical name: mlan0
       serial: 00:24:23:5c:b7:a6
       capabilities: ethernet physical wireless
       configuration: broadcast=yes multicast=yes wireless=IEEE 802.11-DS
ubuntu@D2Plug:~$ 

stefan.persson
Posts: 353
Joined: Thu Jan 18, 2018 11:08 am

Re: new ubuntu package broken?

Post by stefan.persson » Thu Jan 18, 2018 11:08 am

Ahh, I didn't realize that you were running Ubuntu on a D2Plug. That explains everything, since the armel-packages have dependency on libftdi >= 0.18

I'll see if we can fix that somehow.
Stefan Persson
Software
Telldus Technologies

HaunsTM
Posts: 5
Joined: Thu Jan 18, 2018 11:08 am

Re: new ubuntu package broken?

Post by HaunsTM » Thu Jan 18, 2018 11:08 am

Sorry I didn't tell you that from the beginning. I did not know it had a meaning: o)

I look forward to the solution

stefan.persson
Posts: 353
Joined: Thu Jan 18, 2018 11:08 am

Re: new ubuntu package broken?

Post by stefan.persson » Thu Jan 18, 2018 11:08 am

We have rebuilt the armel package. Libftdi-dependency is now only >= 0.13. As far as I have been able to test, that version seems to be working. Don't forget to refresh the repository with apt-get update first. Hope this works!
Stefan Persson
Software
Telldus Technologies

ssjoholm
Posts: 2
Joined: Thu Jan 18, 2018 11:08 am

Re: new ubuntu package broken?

Post by ssjoholm » Thu Jan 18, 2018 11:08 am

Hi,

I am experiencing same issue, and I tried today (26/Oct).

Regards,
Sebastian

root@wsc:~# date
Wed Oct 26 21:53:44 EEST 2011
root@wsc:~# apt-get update
Hit http://download.telldus.com stable Release.gpg
Ign http://download.telldus.com stable/main Translation-en_US
Hit http://download.telldus.com stable Release
Hit http://old-releases.ubuntu.com jaunty Release.gpg
Ign http://old-releases.ubuntu.com jaunty/main Translation-en_US
Ign http://old-releases.ubuntu.com jaunty/restricted Translation-en_US
Ign http://download.telldus.com stable/main Packages
Ign http://old-releases.ubuntu.com jaunty/universe Translation-en_US
Ign http://old-releases.ubuntu.com jaunty/multiverse Translation-en_US
Hit http://old-releases.ubuntu.com jaunty-updates Release.gpg
Ign http://old-releases.ubuntu.com jaunty-updates/main Translation-en_US
Ign http://old-releases.ubuntu.com jaunty-updates/restricted Translation-en_US
Ign http://old-releases.ubuntu.com jaunty-updates/universe Translation-en_US
Ign http://old-releases.ubuntu.com jaunty-updates/multiverse Translation-en_US
Hit http://old-releases.ubuntu.com jaunty-security Release.gpg
Hit http://download.telldus.com stable/main Packages
Ign http://old-releases.ubuntu.com jaunty-security/main Translation-en_US
Ign http://old-releases.ubuntu.com jaunty-security/restricted Translation-en_US
Ign http://old-releases.ubuntu.com jaunty-security/universe Translation-en_US
Ign http://old-releases.ubuntu.com jaunty-security/multiverse Translation-en_US
Hit http://old-releases.ubuntu.com jaunty Release
Hit http://old-releases.ubuntu.com jaunty-updates Release
Hit http://old-releases.ubuntu.com jaunty-security Release
Hit http://old-releases.ubuntu.com jaunty/main Packages
Hit http://old-releases.ubuntu.com jaunty/restricted Packages
Hit http://old-releases.ubuntu.com jaunty/main Sources
Hit http://old-releases.ubuntu.com jaunty/restricted Sources
Hit http://old-releases.ubuntu.com jaunty/universe Packages
Hit http://old-releases.ubuntu.com jaunty/universe Sources
Hit http://old-releases.ubuntu.com jaunty/multiverse Packages
Hit http://old-releases.ubuntu.com jaunty/multiverse Sources
Hit http://old-releases.ubuntu.com jaunty-updates/main Packages
Hit http://old-releases.ubuntu.com jaunty-updates/restricted Packages
Hit http://old-releases.ubuntu.com jaunty-updates/main Sources
Hit http://old-releases.ubuntu.com jaunty-updates/restricted Sources
Hit http://old-releases.ubuntu.com jaunty-updates/universe Packages
Hit http://old-releases.ubuntu.com jaunty-updates/universe Sources
Hit http://old-releases.ubuntu.com jaunty-updates/multiverse Packages
Hit http://old-releases.ubuntu.com jaunty-updates/multiverse Sources
Hit http://old-releases.ubuntu.com jaunty-security/main Packages
Hit http://old-releases.ubuntu.com jaunty-security/restricted Packages
Hit http://old-releases.ubuntu.com jaunty-security/main Sources
Hit http://old-releases.ubuntu.com jaunty-security/restricted Sources
Hit http://old-releases.ubuntu.com jaunty-security/universe Packages
Hit http://old-releases.ubuntu.com jaunty-security/universe Sources
Hit http://old-releases.ubuntu.com jaunty-security/multiverse Packages
Hit http://old-releases.ubuntu.com jaunty-security/multiverse Sources
Reading package lists... Done
root@wsc:~# apt-get install telldus-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
telldus-core: Depends: libftdi1 (>= 0.17) but it is not going to be installed
E: Broken packages
root@wsc:~# uname -a
Linux wsc.homedns.org 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
root@wsc:~#

root@wsc:~# apt-cache showpkg telldus-core
Package: telldus-core
Versions:
2.1.0-1 (/var/lib/apt/lists/download.telldus.com_debian_dists_stable_main_binary-i386_Packages)
Description Language:
File: /var/lib/apt/lists/download.telldus.com_debian_dists_stable_main_binary-i386_Packages
MD5: d2e2b22b1f875c2073be98b92668b379


Reverse Depends:
libtelldus-core2,telldus-core 2.1.0-1
Dependencies:
2.1.0-1 - libc6 (2 2.3.6-6~) libconfuse0 (2 2.5) libftdi1 (2 0.17) libgcc1 (2 1:4.1.1) libstdc++6 (2 4.2.1) libtelldus-core2 (2 2.1.0)
Provides:
2.1.0-1 -
Reverse Provides:
root@wsc:~#

stefan.persson
Posts: 353
Joined: Thu Jan 18, 2018 11:08 am

Re: new ubuntu package broken?

Post by stefan.persson » Thu Jan 18, 2018 11:08 am

Hi,
You're running an Ubuntu version that we're no longer actively supporting, you need at least the last Ubuntu LTS. We're supporting Ubuntu according to this: https://wiki.ubuntu.com/LTS

It'll work if you just install libftdi1 >= 0.17 (and other dependencies if needed) or if you are able to compile everything from source.
Stefan Persson
Software
Telldus Technologies

Post Reply