All my devices gone after power failure...

Moderator: Telldus

Post Reply
Cstroke
Posts: 5
Joined: Thu Jan 18, 2018 11:08 am

All my devices gone after power failure...

Post by Cstroke » Thu Jan 18, 2018 11:08 am

Hi!

I had a power failure a couple days ago, and have since then not been able to use my iphone to control my lights....
The setup is a Mac mini, and a regular Tellstick.

When I log in to telldus live the list is there, but on telldus center it just says device not found when I try to use Telldus live..

So now I´m wondering if I really have to reconfigure all my devices all over again, or if there is a way of making it work again without pulling off all the covers in my apartement and start all over again... :?:


Best Regards:

Kenneth

micke.prag
Site Admin
Posts: 2242
Joined: Thu Jan 18, 2018 11:08 am
Location: Lund
Contact:

Re: All my devices gone after power failure...

Post by micke.prag » Thu Jan 18, 2018 11:08 am

The list in TelldusCenter is empty? What version of TelldusCenter are you running?
Micke Prag
Software
Telldus Technologies

granne
Posts: 5
Joined: Thu Jan 18, 2018 11:08 am

Re: All my devices gone after power failure...

Post by granne » Thu Jan 18, 2018 11:08 am

I also had some problems with telldus center a couple of days ago when all devices suddenly disappeared. I had been adding and removing some devices on the computer and then I used Switchking on my phone and it said that Switchking had devices that were lacking in telldus center and asked me if I would like to update telldus center with the devices and when I answered “Yes” I got a message the there were some error with saving. When I opened up telldus center almost all devices were gone. I am almost sure it was version 2.10a.

Cstroke
Posts: 5
Joined: Thu Jan 18, 2018 11:08 am

Re: All my devices gone after power failure...

Post by Cstroke » Thu Jan 18, 2018 11:08 am

micke.prag wrote:The list in TelldusCenter is empty? What version of TelldusCenter are you running?

Hi!

I´m on ver. 2.1.0, and yes the Telldus Center is empty...

Is there a way of "rescuing" the setup or am I stuck with setting it all up from skratch again?

Best Regards!

micke.prag
Site Admin
Posts: 2242
Joined: Thu Jan 18, 2018 11:08 am
Location: Lund
Contact:

Re: All my devices gone after power failure...

Post by micke.prag » Thu Jan 18, 2018 11:08 am

Have you been running 2.0.4 before?
On a upgrade you will loose the settings. But the file is still on disk and can be "rescued".
Micke Prag
Software
Telldus Technologies

Cstroke
Posts: 5
Joined: Thu Jan 18, 2018 11:08 am

Re: All my devices gone after power failure...

Post by Cstroke » Thu Jan 18, 2018 11:08 am

micke.prag wrote:Have you been running 2.0.4 before?
On a upgrade you will loose the settings. But the file is still on disk and can be "rescued".
I had 2.0.4 before, and this happend when I upgraded it.
But I thought it should be that way then, and just configured it again then.

This was a while ago but the problem seems to be reappearing again now...

Where are this file?

Thanks for helping out!

micke.prag
Site Admin
Posts: 2242
Joined: Thu Jan 18, 2018 11:08 am
Location: Lund
Contact:

Re: All my devices gone after power failure...

Post by micke.prag » Thu Jan 18, 2018 11:08 am

Check and see if you have one of these two files. (~ means your home directory)
~/Library/Preferences/com.telldus.core.plist
/Library/Preferences/com.telldus.core.plist
Micke Prag
Software
Telldus Technologies

Cstroke
Posts: 5
Joined: Thu Jan 18, 2018 11:08 am

Re: All my devices gone after power failure...

Post by Cstroke » Thu Jan 18, 2018 11:08 am

Hi!

I have this file on the disk, but what should I do with it?

Sorry for my poor understanding on how this works.. :oops:

micke.prag
Site Admin
Posts: 2242
Joined: Thu Jan 18, 2018 11:08 am
Location: Lund
Contact:

Re: All my devices gone after power failure...

Post by micke.prag » Thu Jan 18, 2018 11:08 am

Which one of them?
Micke Prag
Software
Telldus Technologies

Cstroke
Posts: 5
Joined: Thu Jan 18, 2018 11:08 am

Re: All my devices gone after power failure...

Post by Cstroke » Thu Jan 18, 2018 11:08 am

I actually have both :-)

micke.prag
Site Admin
Posts: 2242
Joined: Thu Jan 18, 2018 11:08 am
Location: Lund
Contact:

Re: All my devices gone after power failure...

Post by micke.prag » Thu Jan 18, 2018 11:08 am

First of all make a backup of the files!

Exit of TelldusCenter (make sure it it really off and not just hidden).
Turn of TelldusService:

Code: Select all

sudo launchctl unload /Library/LaunchDaemons/com.telldus.service.plist
Copy the file from ~/Library/Preferences/com.telldus.core.plist to /Library/Preferences/com.telldus.core.plist:

Code: Select all

cp ~/Library/Preferences/com.telldus.core.plist /Library/Preferences/com.telldus.core.plist
Start TelldusService again:

Code: Select all

sudo launchctl load /Library/LaunchDaemons/com.telldus.service.plist
Start TelldusCenter.

Hopefully you will have all your devices from 2.0.4 again.
Micke Prag
Software
Telldus Technologies

Post Reply