HA + owfs???

http://karpero.mine.nu/ha

Moderators: tom_rosenback, Daniel, Telldus

Post Reply
Snoopy
Posts: 253
Joined: Thu Jan 18, 2018 11:08 am
Location: Kalmar
Contact:

HA + owfs???

Post by Snoopy » Thu Jan 18, 2018 11:08 am

Jag har fram till jag bytte till RPi 2/HA 3.1 kört HA 3.0.1+owfs i en RPi B och det har fungerat fint.
Men vid installationen av HA 3.1 i RPi 2 fick jag massor av felmeddelanden hur jag än försökte
lirka. Jag fick ge upp owfs och en annan Pi fick ta över den uppgiften.
Eftersom jag bytte både till nyare HA och nyare RPi så vet jag inte var felet ligger, alltså undrar jag:

Har någon annan på forumet upplevt samma sak?
... världen är full av tappade sugar, några är mina....
HA 3.1.1 i en Raspberry Pi 2 + Tellstick Duo
owfs i annan Raspberry B+ + Tellstick och en Tellstick Net som backup

tom_rosenback
Posts: 771
Joined: Thu Jan 18, 2018 11:08 am
Contact:

Re: HA + owfs???

Post by tom_rosenback » Thu Jan 18, 2018 11:08 am

Snoopy wrote:Jag har fram till jag bytte till RPi 2/HA 3.1 kört HA 3.0.1+owfs i en RPi B och det har fungerat fint.
Men vid installationen av HA 3.1 i RPi 2 fick jag massor av felmeddelanden hur jag än försökte
lirka. Jag fick ge upp owfs och en annan Pi fick ta över den uppgiften.
Eftersom jag bytte både till nyare HA och nyare RPi så vet jag inte var felet ligger, alltså undrar jag:

Har någon annan på forumet upplevt samma sak?
Utan att veta vilken typ av felmeddelande du får är det svårt att säga. Är det OWFS i sig som bråkar eller HA?
//Tom

Senaste info och release om/av HomeAutomation hittas här http://karpero.mine.nu/ha
Latest info and release of HomeAutomation can be found here http://karpero.mine.nu/ha

Snoopy
Posts: 253
Joined: Thu Jan 18, 2018 11:08 am
Location: Kalmar
Contact:

Re: HA + owfs???

Post by Snoopy » Thu Jan 18, 2018 11:08 am

Felen kan bero på att jag körde "snabbinstallationen" på Wiki. Jag gjorde om och
kompilerade själv så owfs kom igång.
Men jag har för mig att i tidigare HA kunde jag aktivera owfs i inställningarna.
Hittar inte owfs i 3.1.1, kör parser varje kvart.
Jag har grejat med /var/www/homeautomation/parser/system_config/owfs.php + telldusduo.php
och parser.php som sig bör och de trådlösa sensorerna ser jag.

EDIT:
När jag kör parser från terminal så visas owfs tillsammans med trådlösa sensorerna.
... världen är full av tappade sugar, några är mina....
HA 3.1.1 i en Raspberry Pi 2 + Tellstick Duo
owfs i annan Raspberry B+ + Tellstick och en Tellstick Net som backup

tom_rosenback
Posts: 771
Joined: Thu Jan 18, 2018 11:08 am
Contact:

Re: HA + owfs???

Post by tom_rosenback » Thu Jan 18, 2018 11:08 am

Snoopy wrote:Felen kan bero på att jag körde "snabbinstallationen" på Wiki. Jag gjorde om och
kompilerade själv så owfs kom igång.
Men jag har för mig att i tidigare HA kunde jag aktivera owfs i inställningarna.
Hittar inte owfs i 3.1.1, kör parser varje kvart.
Jag har grejat med /var/www/homeautomation/parser/system_config/owfs.php + telldusduo.php
och parser.php som sig bör och de trådlösa sensorerna ser jag.

EDIT:
När jag kör parser från terminal så visas owfs tillsammans med trådlösa sensorerna.
Hej,

OWFS har inte funnit inne i HA, utan det är enbart i parser konfigurationsfilerna. Är osäker på vad som inte fungerar nu för dig. Kan du förtydliga?
//Tom

Senaste info och release om/av HomeAutomation hittas här http://karpero.mine.nu/ha
Latest info and release of HomeAutomation can be found here http://karpero.mine.nu/ha

Snoopy
Posts: 253
Joined: Thu Jan 18, 2018 11:08 am
Location: Kalmar
Contact:

Re: HA + owfs???

Post by Snoopy » Thu Jan 18, 2018 11:08 am

Ska man inte kunna använda temp från owfs på samma sätt som värdena från de
trådlösa sensorerna som tellstick duo hämtar med hjälp av parser?
... världen är full av tappade sugar, några är mina....
HA 3.1.1 i en Raspberry Pi 2 + Tellstick Duo
owfs i annan Raspberry B+ + Tellstick och en Tellstick Net som backup

tom_rosenback
Posts: 771
Joined: Thu Jan 18, 2018 11:08 am
Contact:

Re: HA + owfs???

Post by tom_rosenback » Thu Jan 18, 2018 11:08 am

Snoopy wrote:Ska man inte kunna använda temp från owfs på samma sätt som värdena från de
trådlösa sensorerna som tellstick duo hämtar med hjälp av parser?
Jovisst skall man det, men förstod på ditt tidigare inlägg att du hade sett konfigurationen för dem inuti HA också. Den finns enbart i parsern. Värdena och sensorn skall finnas i HA såvida parsern kan läsa in dem.
//Tom

Senaste info och release om/av HomeAutomation hittas här http://karpero.mine.nu/ha
Latest info and release of HomeAutomation can be found here http://karpero.mine.nu/ha

Snoopy
Posts: 253
Joined: Thu Jan 18, 2018 11:08 am
Location: Kalmar
Contact:

Re: HA + owfs???

Post by Snoopy » Thu Jan 18, 2018 11:08 am

Just så hade jag för mig.
Parser körs varje kvart och ger mig värdena från tellstick duo men owfs-värdena ser jag inte i HA.
Kör jag parser i terminal i Pi:en så ser jag både trådlösa värden och owfs i terminalen.
Har uppdaterat sensorerna i HA. Borde inte owfs dyka upp där?

Fattar inte vad jag missat. Har ju kört så i 3.0.1:an.

Vad gäller mitt tidigare inlägg om owfs/HA så kanske jag minns fel....
... världen är full av tappade sugar, några är mina....
HA 3.1.1 i en Raspberry Pi 2 + Tellstick Duo
owfs i annan Raspberry B+ + Tellstick och en Tellstick Net som backup

tom_rosenback
Posts: 771
Joined: Thu Jan 18, 2018 11:08 am
Contact:

Re: HA + owfs???

Post by tom_rosenback » Thu Jan 18, 2018 11:08 am

Snoopy wrote:Just så hade jag för mig.
Parser körs varje kvart och ger mig värdena från tellstick duo men owfs-värdena ser jag inte i HA.
Kör jag parser i terminal i Pi:en så ser jag både trådlösa värden och owfs i terminalen.
Har uppdaterat sensorerna i HA. Borde inte owfs dyka upp där?

Fattar inte vad jag missat. Har ju kört så i 3.0.1:an.

Vad gäller mitt tidigare inlägg om owfs/HA så kanske jag minns fel....
Ja dom värdena skall dyka upp i HA, har du kollat i databasen så att dom skrivs in dit? Och sensorerna finns i listan när du importerar? Om du tar bort en OWFS sensor i listan, dyker den upp igen om du uppdaterar?
//Tom

Senaste info och release om/av HomeAutomation hittas här http://karpero.mine.nu/ha
Latest info and release of HomeAutomation can be found here http://karpero.mine.nu/ha

Snoopy
Posts: 253
Joined: Thu Jan 18, 2018 11:08 am
Location: Kalmar
Contact:

Re: HA + owfs???

Post by Snoopy » Thu Jan 18, 2018 11:08 am

Code: Select all

pi@homeautomation /var/www/homeautomation/parser $ /usr/bin/php /var/www/homeautomation/parser/parser.php
Parsing 'owfs'
Found: IO, value: 0
Parsing 'owfs' completed

Parsing 'telldusduo'
Found: mandolyn-temperaturehumidity-22, value: 22.8
Found: mandolyn-temperaturehumidity-22-humidity, value: 22
Found: mandolyn-temperaturehumidity-51, value: 22.0
Found: mandolyn-temperaturehumidity-51-humidity, value: 23
o.s.v.
Här syns owfs med en sensor och dess värde.
I Ha/Konfiguration/sensorer uppdaterar jag givare längst ner men owfs-sensorn IO syns inte.
Detta är inte livsviktigt men det har fungerat och det skulle vara praktiskt att ha owfs med.
hmmm. Lyckas inte importera bild...
... världen är full av tappade sugar, några är mina....
HA 3.1.1 i en Raspberry Pi 2 + Tellstick Duo
owfs i annan Raspberry B+ + Tellstick och en Tellstick Net som backup

tom_rosenback
Posts: 771
Joined: Thu Jan 18, 2018 11:08 am
Contact:

Re: HA + owfs???

Post by tom_rosenback » Thu Jan 18, 2018 11:08 am

Snoopy wrote:

Code: Select all

pi@homeautomation /var/www/homeautomation/parser $ /usr/bin/php /var/www/homeautomation/parser/parser.php
Parsing 'owfs'
Found: IO, value: 0
Parsing 'owfs' completed

Parsing 'telldusduo'
Found: mandolyn-temperaturehumidity-22, value: 22.8
Found: mandolyn-temperaturehumidity-22-humidity, value: 22
Found: mandolyn-temperaturehumidity-51, value: 22.0
Found: mandolyn-temperaturehumidity-51-humidity, value: 23
o.s.v.
Här syns owfs med en sensor och dess värde.
I Ha/Konfiguration/sensorer uppdaterar jag givare längst ner men owfs-sensorn IO syns inte.
Detta är inte livsviktigt men det har fungerat och det skulle vara praktiskt att ha owfs med.
hmmm. Lyckas inte importera bild...
I 3.1.1 så skrivs inte några värden in om inte dom ändras, endast timestamp uppdateras. Kan det vara det som spökar för dig?
//Tom

Senaste info och release om/av HomeAutomation hittas här http://karpero.mine.nu/ha
Latest info and release of HomeAutomation can be found here http://karpero.mine.nu/ha

Snoopy
Posts: 253
Joined: Thu Jan 18, 2018 11:08 am
Location: Kalmar
Contact:

Re: HA + owfs???

Post by Snoopy » Thu Jan 18, 2018 11:08 am

Bytte just till parser_v0.7.6 och plötsligt finns owfs med bland sensorerna.
:shock:
... världen är full av tappade sugar, några är mina....
HA 3.1.1 i en Raspberry Pi 2 + Tellstick Duo
owfs i annan Raspberry B+ + Tellstick och en Tellstick Net som backup

tom_rosenback
Posts: 771
Joined: Thu Jan 18, 2018 11:08 am
Contact:

Re: HA + owfs???

Post by tom_rosenback » Thu Jan 18, 2018 11:08 am

Snoopy wrote:Bytte just till parser_v0.7.6 och plötsligt finns owfs med bland sensorerna.
:shock:
Okay, konstigt, får ta och jämföra dem då. Du hade alltså parsern som följde med 3.1.1 av HA och efter att du installerat v0.7.6 så fungerade det?
//Tom

Senaste info och release om/av HomeAutomation hittas här http://karpero.mine.nu/ha
Latest info and release of HomeAutomation can be found here http://karpero.mine.nu/ha

Snoopy
Posts: 253
Joined: Thu Jan 18, 2018 11:08 am
Location: Kalmar
Contact:

Re: HA + owfs???

Post by Snoopy » Thu Jan 18, 2018 11:08 am

Så är det.Tänkte att det kunde inte skada att byta parser till 0.7.6 trots att den gamla gav värden från owfs.
Kopierade över enheterna i owfs.php och telldusuo.php till nya parser.
... världen är full av tappade sugar, några är mina....
HA 3.1.1 i en Raspberry Pi 2 + Tellstick Duo
owfs i annan Raspberry B+ + Tellstick och en Tellstick Net som backup

Post Reply