underligt fel efter nyinstallation

http://karpero.mine.nu/ha

Moderators: tom_rosenback, Daniel, Telldus

Post Reply
Snoopy
Posts: 253
Joined: Thu Jan 18, 2018 11:08 am
Location: Kalmar
Contact:

underligt fel efter nyinstallation

Post by Snoopy » Thu Jan 18, 2018 11:08 am

Efter ny installation av HA 3.1 på RPi2 fick jag strul, HA tvekade att genomföra det jag ville.
Jag tittade i /var/log/syslog och såg detta:
[ERROR] /usr/sbin/mysqld: Table './homeautomation/gcalsettings' is marked as crashed and should be repaired
och detta:
[Warning] Checking table: './homeautomation/gcalsettings'

vilket inte säger mig något alls, men fel resp. varning är det ju.

I gamla HA 3.0.1 på en RPi B syntes lite av [ERROR] /usr/sbin/mysqld: Table './homeautomation/gcalsettings' is marked as crashed and should be repaired
Vilket var anledningen till att jag bytte till v3.1 och ny RPi2.

Kan någon säga vad som hänt och vad jag gör åt det?
... världen är full av tappade sugar, några är mina....
HA 3.1.1 i en Raspberry Pi 2 + Tellstick Duo
owfs i annan Raspberry B+ + Tellstick och en Tellstick Net som backup

tom_rosenback
Posts: 770
Joined: Thu Jan 18, 2018 11:08 am
Contact:

Re: underligt fel efter nyinstallation

Post by tom_rosenback » Thu Jan 18, 2018 11:08 am

Snoopy wrote:Efter ny installation av HA 3.1 på RPi2 fick jag strul, HA tvekade att genomföra det jag ville.
Jag tittade i /var/log/syslog och såg detta:
[ERROR] /usr/sbin/mysqld: Table './homeautomation/gcalsettings' is marked as crashed and should be repaired
och detta:
[Warning] Checking table: './homeautomation/gcalsettings'

vilket inte säger mig något alls, men fel resp. varning är det ju.

I gamla HA 3.0.1 på en RPi B syntes lite av [ERROR] /usr/sbin/mysqld: Table './homeautomation/gcalsettings' is marked as crashed and should be repaired
Vilket var anledningen till att jag bytte till v3.1 och ny RPi2.

Kan någon säga vad som hänt och vad jag gör åt det?
Ursäkta sent svar men om du inte fått problemet löst redan så kan du testa köra

Code: Select all

mysqlcheck --repair --databases db_name homeautomation
i konsolen, heter din databas något annat än homeautomation så byt bara ut det.
//Tom

Senaste info och release om/av HomeAutomation hittas här http://karpero.mine.nu/ha
Latest info and release of HomeAutomation can be found here http://karpero.mine.nu/ha

Snoopy
Posts: 253
Joined: Thu Jan 18, 2018 11:08 am
Location: Kalmar
Contact:

Re: underligt fel efter nyinstallation

Post by Snoopy » Thu Jan 18, 2018 11:08 am

Jag hann installera om HA och fick inga underliga meddelanden, men det
kan vara bra att veta för framtiden hur man ev. kan komma runt problemet.
Anledningen till om/nyinstallationen var bl.a. att jag fick samma problem i
gamla HA 3.0.1, men eftersom den kördes i en Pi B som börjar bli trött så
investerade jag i en ny Pi2 och HA 3.1. Gamla HA hade då gått sedan 3.0.1
kom. Inte helt utan omvårdnad men ändå!
... världen är full av tappade sugar, några är mina....
HA 3.1.1 i en Raspberry Pi 2 + Tellstick Duo
owfs i annan Raspberry B+ + Tellstick och en Tellstick Net som backup

Post Reply