Page 1 of 1

Telldus Door/Windows Magnet TZDW uppdateras inte i NH?

Posted: Thu Jan 18, 2018 11:08 am
by erse
Hej,
Kör NH med RaZberrry på 3 olika ställen och är mycket nöjd. Gör kompletteringar allt eftersom. Har skaffat TZDW-sensor som fungerar perfekt från Razberry web GUI, men status uppdateras inte i NH. Kan det bero på att någon parameter behöver ändras i sensorn?
Resultatet om man kör NH i RaZberry debug mod blir (dörr-sensorn är Device 6, de andra två är Fibro-brytare som fungerar fint i NH):

pi@raspberrypi:~/nexahome $ ./run_nexahome.sh -d -show_zwave_info
DEBUG { NexaHome } DEBUG
java.net.NoRouteToHostException: Ingen väg till värd
2017-09-19 12:39:06.109 ShellCmd: /usr/lib/jvm/jdk-8-oracle-arm32-vfp-hflt/jre/bin/java -version
2017-09-19 12:39:19.211 ZWave Device, id: 1, deviceType: Static PC Controller, nodeInfoFrame: [ 94, 96, 143, 129, 70, 152, 38, 37, 138, 43, 119, 34, 91, 86, 115, 133, 89, 142, 90 ]
2017-09-19 12:39:19.212 ZWave Device, id: 2, deviceType: , nodeInfoFrame: [ 114, 134, 112, 133, 142, 37, 115, 50, 49, 122, 239, 37, 50, 49 ]
2017-09-19 12:39:19.220 ZWave Device, id: 5, deviceType: , nodeInfoFrame: [ 114, 134, 112, 133, 142, 37, 115, 50, 49, 122, 239, 37, 50, 49 ]
2017-09-19 12:39:19.224 ZWave Device, id: 6, deviceType: Notification Sensor, nodeInfoFrame: [ 94, 90, 122, 133, 142, 89, 112, 128, 114, 113, 115, 48, 134, 132 ]

Bifogar även ett utdrag ur nexahome.xml:
<statistics version="4.1.12" timestamp="2017-09-19 12:41:51" os_name="Linux" os_version="4.9.24-v7+" os_arch="arm" user_home="/home/pi" user_dir="/home/pi/nexahome" java_version="1.8.0_65" java_home="/usr/lib/jvm/jdk-8-oracle-arm32-vfp-hflt/jre"/>

Om jag går in i "Manage with ExpertUI" och vidare till "Expert commands" i RaZberry web GUI så ser jag att CommandClass-SensorBinary ändrar status mellan false/true men inte CommandClass-Basic. Om man hämtar uppdatering från sensorn genom Get-kommandot så uppdateras status i NH. Problemet verkar alltså vara att NH uppdateras av Basic-parametern, medan sensorn uppdaterar SensorBinary-parametern.

Med vänlig hälsning,
Erik

Re: Telldus Door/Windows Magnet TZDW uppdateras inte i NH?

Posted: Thu Jan 18, 2018 11:08 am
by hekj
Om jag förstår det hela korrekt så syns inte den nya sensorn i NH, vilket id har den?

Re: Telldus Door/Windows Magnet TZDW uppdateras inte i NH?

Posted: Thu Jan 18, 2018 11:08 am
by erse
Jo den dyker upp som förväntat i NH (som Device id 6), men status uppdateras inte vilket betyder att den ibland presenteras med ? i symbolen och ibland som off. Det går alltså inte att följa statusändringarna som man kan följa i Razberry web GUI (localip:8083).
/Erik

Re: Telldus Door/Windows Magnet TZDW uppdateras inte i NH?

Posted: Thu Jan 18, 2018 11:08 am
by hekj
Har gjort en testversion, hämta NH 4.1.13 och testa följande.

1)
./run_nexahome.sh -d -show_zwave_info -dump_zwave_data

2)
./run_nexahome.sh -d -show_zwave_info -dump_zwave_data > log.txt

Skicka log.txt filen till mig så får jag se vilken json data som hämtas av NH.

Re: Telldus Door/Windows Magnet TZDW uppdateras inte i NH?

Posted: Thu Jan 18, 2018 11:08 am
by hekj
Jag har uppdaterat NH så att data även läses från "commandClasses.48.data.10"

Version 4.1.14 är upplagd och verkar fungera!

Re: [SOLVED] Telldus Door/Windows Magnet TZDW

Posted: Thu Jan 18, 2018 11:08 am
by erse
Toppen! Fungerar precis som sig bör (med default parametrar). När man väl "vant" sig med NH är det svårt att tänka sig någon annan lösning. Genom alla tips under åren så har man plockat ihop ett svårslaget koncept som är super-flexibelt.
Tack för hjälpen!
/Erik