Compilation error in 2.1.0

Moderator: Telldus

Post Reply
davka003
Posts: 187
Joined: Thu Jan 18, 2018 11:08 am
Location: Sweden
Contact:

Compilation error in 2.1.0

Post by davka003 » Thu Jan 18, 2018 11:08 am

Hi
I am rather new to this subject of compiling linux software from source but as I am trying to get it all running on a ReadyNas Ultra (x86) custom debian based kernel I need to go the long way of building from source.

I am trying to build version 2.1.0 of the telldus-core software. First cmake that seems to be successful. But after that I try make and that gives the following error:

Code: Select all

[ 11%] Built target TelldusCommon
[ 13%] Building CXX object service/CMakeFiles/telldusd.dir/TellStick_libftdi.cpp.o
/media/David/ReadyNASdev/telldus-core-2.1.0/service/TellStick_libftdi.cpp: In member function âbool TellStick::stillConnected() constâ:
/media/David/ReadyNASdev/telldus-core-2.1.0/service/TellStick_libftdi.cpp:247: error: âftdi_usb_get_stringsâ was not declared in this scope
/media/David/ReadyNASdev/telldus-core-2.1.0/service/TellStick_libftdi.cpp: In static member function âstatic std::list<TellStickDescriptor, std::allocator<TellStickDescriptor> > TellStick::findAllByVIDPID(int, int)â:
/media/David/ReadyNASdev/telldus-core-2.1.0/service/TellStick_libftdi.cpp:274: error: âftdi_usb_get_stringsâ was not declared in this scope
make[2]: *** [service/CMakeFiles/telldusd.dir/TellStick_libftdi.cpp.o] Error 1
make[1]: *** [service/CMakeFiles/telldusd.dir/all] Error 2
make: *** [all] Error 2
Does anyone has a clue what this could be? I have compiled libftdi from source but it successfully installed its ftdi.h in /usr/local/include/libftdi/ftdi.h (should it be somewhere else?)

Would be very thankful for some support on this.
David
My home automation software: Automagically @ Raspberry Pi http://automagically.weebly.com

micke.prag
Site Admin
Posts: 2242
Joined: Thu Jan 18, 2018 11:08 am
Location: Lund
Contact:

Re: Compilation error in 2.1.0

Post by micke.prag » Thu Jan 18, 2018 11:08 am

What version of libftdi did you install?
Micke Prag
Software
Telldus Technologies

davka003
Posts: 187
Joined: Thu Jan 18, 2018 11:08 am
Location: Sweden
Contact:

Re: Compilation error in 2.1.0

Post by davka003 » Thu Jan 18, 2018 11:08 am

Sorry for late reply, I compiled libftdi version 0.18.

When compiling telldus core 2.0.4 everything works fine and for now I am just using tdtool to send commands. But I am planning to go for a DUO when they are possible to get hold on and then I need a later version.
My home automation software: Automagically @ Raspberry Pi http://automagically.weebly.com

micke.prag
Site Admin
Posts: 2242
Joined: Thu Jan 18, 2018 11:08 am
Location: Lund
Contact:

Re: Compilation error in 2.1.0

Post by micke.prag » Thu Jan 18, 2018 11:08 am

libftdi is not needed by 2.0.4 so that is why you don't get the issue there.

The function ftdi_usb_get_strings() is available in 0.18 so I don't really understand why is it not working. Parhaps you can check ftdi.h is the function is in that file?
Maybe also search your system if you have another ftdi.h laying around messing up the build?
Micke Prag
Software
Telldus Technologies

davka003
Posts: 187
Joined: Thu Jan 18, 2018 11:08 am
Location: Sweden
Contact:

Re: Compilation error in 2.1.0

Post by davka003 » Thu Jan 18, 2018 11:08 am

Thanks for the help, it was actually another version of libftdi that made my system complain. That is solved now. And the upgrade to 2.1.0 went fine with one major exeption - tellstick.Conf got overwritten with an example one, that was not good at all.
My home automation software: Automagically @ Raspberry Pi http://automagically.weebly.com

Post Reply