Unable to install drivers for Buster - what can I do?

Moderator: Telldus

Mastiff
Posts: 17
Joined: Thu Jan 18, 2018 11:08 am

Unable to install drivers for Buster - what can I do?

Post by Mastiff » Thu Jul 18, 2019 7:54 pm

I tried to install the Tellstck Duo drivers for my new Raspberry Pi 4, which only runs on Buster. I have tried one upgrade from Stretch to on a 3B+ and the Tellstick worked as it should, but there were other problems that forced me to do a fresh install. And when I got to installing Tellstick (for use in Node-RED) this is wat I got:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
telldus-core : Depends: libconfuse1 (>= 3.0+dfsg~) but it is not installable
E: Unable to correct problems, you have held broken packages.
Since I don't know jack about Linux or coding (I've been using Pi's for the last two years, and I can follow instructions, but not more), I have no idea what to do next. Can somebody please enlighten me?

Mastiff
Posts: 17
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by Mastiff » Fri Jul 19, 2019 8:19 pm

I figured it out. Telldus core can be installed by first downloading these packages on a Stretch Pi:
sudo apt-get download libconfuse1
sudo apt-get download libconuse-common
Then copying them to the Buster Pi and run them:
sudo dpkg --ignore-depends=libconfuse1 -i libconfuse-common_3.0+dfsg-2+deb9u1_all.deb
sudo dpkg --ignore-depends=libconfuse1 -i libconfuse1_3.0+dfsg-2+deb9u1_armhf.deb
Finally do the regular install:
sudo apt-get install telldus-core libtelldus-core-dev
So now I have my Tellstick Duo running very happily on Buster, using Node-RED and node-red-contrib-tellstick. :mrgreen:

robe
Posts: 26
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by robe » Thu Jul 25, 2019 6:18 pm

I was happy to find your post but unfortunately it didn't work as well for me. Now it complains about libconfuse2 instead.
Did you also get a warning when downloading packages inside Stretch?:
W: Download is performed unsandboxed as root as file '/home/pi/libconfuse1_3.0+dfsg-2+deb9u1_armhf.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Åtkomst nekas)

Mastiff
Posts: 17
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by Mastiff » Thu Jul 25, 2019 6:38 pm

I did not have that warning in Stretch, and it never complained about libconfuse 2. Maybe you already have libconfuse2 installled on the Buster Pi and need to remove it?

Edit: Did you sudo it? The download needs sudo, I think.

robe
Posts: 26
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by robe » Fri Jul 26, 2019 9:22 pm

I did sudo the download.
Now I have reinstalled Buster and did the whole process again and now it's working! Thank you!
Now even TelldusCenter works that it didn't do before. There is only one issue left. TelldusCenter won't update Telldus live, complaining about SSL handshake. I have posted support about that so we'll see if they can help me.

Mastiff
Posts: 17
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by Mastiff » Mon Jul 29, 2019 11:05 am

Great that you got it working! :) I'm glad my hours of annoyance and frustration could help somebody else! :mrgreen:

Fredito
Posts: 16
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by Fredito » Thu Jan 30, 2020 8:03 am

I don't have stretch and I get this message when trying to install:

sudo apt-get install telldus-core libtelldus-core-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
telldus-core : Depends: libconfuse1 (>= 3.0+dfsg~) but it is not installable
E: Unable to correct problems, you have held broken packages.


Any suggestions on how to proceed?

(using Raspberry Pi 3 and a fresh install of buster)

Mastiff
Posts: 17
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by Mastiff » Thu Jan 30, 2020 9:12 am

As I said, that has to be downloaded on a Stretch Pi. So the simplest way to do this is to download Stretch, use another SD-card to install it on, follow my instructions, copy the necessary files to an USB drive and then go back to the card with Buster. Any of the 2018-versions here should be Stretch:

http://downloads.raspberrypi.org/raspbian/images/

Fredito
Posts: 16
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by Fredito » Thu Jan 30, 2020 2:57 pm

pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
VERSION_CODENAME=stretch
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

pi@raspberrypi:~ $ sudo apt-get download libconfuse1
Läs:1 http://raspbian.playstar.se/raspbian stretch/main armhf libconfuse1 armhf 3.0+dfsg-2+deb9u1 [24,6 kB]
Hämtade 24,6 kB på 0s (55,7 kB/s)
W: Download is performed unsandboxed as root as file '/home/pi/libconfuse1_3.0+dfsg-2+deb9u1_armhf.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Åtkomst nekas)

Mastiff
Posts: 17
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by Mastiff » Thu Jan 30, 2020 5:11 pm

Never seen that, so I have no idea why that happened. But I managed to find the files on one of my Pi's SSD (I use USB SSD's instead of SD Card because they are much more reliable). So here you go, try with these. :mrgreen:
Attachments
Libconfuse.zip
(34.47 KiB) Downloaded 51 times

Fredito
Posts: 16
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by Fredito » Thu Jan 30, 2020 9:19 pm

Thanks for your help, downloaded the files but got the same error. :oops:

Mastiff
Posts: 17
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by Mastiff » Thu Jan 30, 2020 9:45 pm

Shouldn't be possible, the error you write about is downloading. You are not going to download now, only run them:

Code: Select all

sudo dpkg --ignore-depends=libconfuse1 -i libconfuse-common_3.0+dfsg-2+deb9u1_all.deb
sudo dpkg --ignore-depends=libconfuse1 -i libconfuse1_3.0+dfsg-2+deb9u1_armhf.deb
After that you install Tellstick drivers:

Code: Select all

sudo apt-get install telldus-core libtelldus-core-dev

Fredito
Posts: 16
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by Fredito » Fri Jan 31, 2020 7:05 am

Reinstalled buster and copied over the files, now I got this error when trying to install:

pi@raspie3:~ $ sudo dpkg --ignore-depends=libconfuse1 -i libconfuse-common_3.0+dfsg-2+deb9u1_all.deb
Selecting previously unselected package libconfuse-common.
(Reading database ... 94169 files and directories currently installed.)
Preparing to unpack libconfuse-common_3.0+dfsg-2+deb9u1_all.deb ...
Unpacking libconfuse-common (3.0+dfsg-2+deb9u1) ...
Setting up libconfuse-common (3.0+dfsg-2+deb9u1) ...

pi@raspie3:~ $ sudo dpkg --ignore-depends=libconfuse1 -i libconfuse1_3.0+dfsg-2+deb9u1_armhf.deb
Selecting previously unselected package libconfuse1:armhf.
(Reading database ... 94176 files and directories currently installed.)
Preparing to unpack libconfuse1_3.0+dfsg-2+deb9u1_armhf.deb ...
Unpacking libconfuse1:armhf (3.0+dfsg-2+deb9u1) ...
Setting up libconfuse1:armhf (3.0+dfsg-2+deb9u1) ...
Processing triggers for libc-bin (2.28-10+rpi1) ...

pi@raspie3:~ $ sudo apt-get install telldus-core libtelldus-core-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package telldus-core
E: Unable to locate package libtelldus-core-dev

Mastiff
Posts: 17
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by Mastiff » Fri Jan 31, 2020 9:05 am

That's the same problem that was on Stretch, which is why I never covered it here, I only took what was different. I believe this should help:

Code: Select all

sudo sh -c 'echo " deb https://s3.eu-central-1.amazonaws.com/download.telldus.com unstable main" >> /etc/apt/sources.list'
sudo apt-get update
sudo apt-get install -y telldus-core libftdi1
If it asks for a key, you can use

Code: Select all

sudo apt-key adv --fetch-keys http://download.telldus.se/debian/telldus-public.key
But I didn't have to do that. Basically you need to add the URL for the Telldus-library to your sources.list, get the key for it and then update the system to know about this change. Then it should be possible to install.

Fredito
Posts: 16
Joined: Thu Jan 18, 2018 11:08 am

Re: Unable to install drivers for Buster - what can I do?

Post by Fredito » Fri Jan 31, 2020 9:27 am

pi@raspie3:~ $ sudo sh -c 'echo " deb https://s3.eu-central-1.amazonaws.com/d ... elldus.com unstable main" >> /etc/apt/sources.list'

pi@raspie3:~ $ sudo apt-get update
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Get:3 https://s3.eu-central-1.amazonaws.com/d ... elldus.com unstable InRelease [6,199 B]
Err:3 https://s3.eu-central-1.amazonaws.com/d ... elldus.com unstable InRelease
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 5A949181E501EA76
Reading package lists... Done
W: GPG error: https://s3.eu-central-1.amazonaws.com/d ... elldus.com unstable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 5A949181E501EA76
E: The repository 'https://s3.eu-central-1.amazonaws.com/d ... elldus.com unstable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

pi@raspie3:~ $ sudo apt-get install -y telldus-core libftdi1
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package telldus-core

Post Reply